Issues executing multiprocessors with pvserver/pvrenderserver/pvdataserver

I am having issues with the multi-processor method on Paraview. I have tried to utilize pvserver, pvdataserver and pvrenderserver. I tried to run 5.8.1 directly on Jarvis (our large processing machine) but the graphics card is not compatible, so I am forced to remote into Jarvis and try to utilize those processors. If I try to use pvserver to speed up my post-processing I run into the following issues:

  1. Paraview crashes and says the state is unrecoverable
  • I have had this software crash on me more than I can count.
  1. It takes up to an hour or maybe more to load filters
  • If I try to move to the next cycle in the spcth file, I am doomed to wait another hour if it doesn’t crash
  1. I have gotten as far as exporting spreadsheets from the fragments but when I export them, a lot of the data reads ‘nan’ and the mass reads as 0. If I get that far using multi processors it will crash. I have not gotten as far as exporting spreadsheets and doing work after when running more than one processor.

  2. If I save a state using multi processors and tried to load it later, I have never been successful in loading it.

  • I received the following error after an hour of loading
  • (3406.418s) [pvserver ] vtkDATAWriter.cxx:1939 WARN] vtkPolyWriter (0x2cf89d1e0): Skipping key ‘vtkDataArray::L2_NORM_FINITE_RANGE’: bad value: -nan
  • (3406.419s) [pvserver ] vtkDATAWriter.cxx:1939 WARN] vtkPolyWriter (0x2cf89d1e0): Skipping key ‘vtkDataArray::L2_NORM_RANGE’: bad value: -nan
  1. My connection is working but the software is just not cooperating with multi processors. The concern I see is, when I use the command top in command window, I will see that pvserver is using above 100% CPU for that processor which is impossible. It will get as high as 5000%.

  2. I did try to use “pv…” with just 1 processor on Jarvis and that actually loaded my work after 2 hours. The issue is using 1 processor defeats the purpose.