json vtr.series loading in Paraview 5.10

Dear Paraview community,

I am trying to add the simulated time to a time series which would really make my animations more readable. I follow the JSON .vtr.series formatting, like so:

    "file-series-version" : "1.0",
    "files": [ 
       { "name" : "doab10.vtr", "time" : 60.0},
       { "name" : "doab20.vtr", "time" : 55793.8978},
       { "name" : "doab30.vtr", "time" : 98228.6093},
       { "name" : "doab40.vtr", "time" : 154165.5208},
       { "name" : "doab50.vtr", "time" : 199414.8669},
       { "name" : "doab60.vtr", "time" : 235629.7501},
       { "name" : "doab70.vtr", "time" : 269426.7697},
       { "name" : "doab2540.vtr", "time" : 9827530.7055}

I know about the comma sensitivity (e.g. no comma after the last entry). I have been able to use .vtr.series files generated with this script in Paravier 5.9, but since upgrading to 5.10 it stopped working, I can select the doab.vtr.series file in Paraview GUI but it then asks to select a reader (no .vtr reader option provided). Did this functionality change between 5.9 and 5.10, or am I overlooking something obvious?

Thanks in advance!
This is the output of my paraview server when I select the .vtr.series file:

luuk@holykauw ~ $ ./ParaView-5.10.1-egl-MPI-Linux-Python3.9-x86_64/bin/pvserver --force-offscreen-rendering
Waiting for client...
Connection URL: cs://holykauw:11111
Accepting connection(s): holykauw:11111
Client connected.
ERROR 4: `/media/luuk/epsilonv8x/distalorogenesis/doab/doab.vtr.series' not recognised as a supported file format.

ERROR 10: Pointer 'hDS' is NULL in 'GDALClose'.

/home/luuk/ParaView-5.10.1-egl-MPI-Linux-Python3.9-x86_64/lib/python3.9/site-packages/pandas/compat/__init__.py:124: UserWarning: Could not import the lzma module. Your installed Python is incomplete. Attempting to use lzma compression will result in a RuntimeError.

I attach the .vtr.series file. The .vtr data files are 600 MB each, so I just upload one below.
doab.vtr.series (14.0 KB)

Hi @Luukv8x ,

It is working fine here. Please share a data to reproduce the issue.


I edited the post above with more details and a sample output file. I hope it helps!

your files are incorrectly named:

{ "name" : "doab400.vtr", "time" : 1010132.3158},

$ ls doab*
doab_400.vtr  doab.vtr.series
1 Like

I can’t believe I missed that… thank you @mwestphal :smiley:

1 Like