LagrangianParticleTracker issue

I am starting to use Paraview 5.10.0-RC1 on Windows10 to do Lagrangian Particle Tracking.
I start by loading a .vtu file generated with SimVascular, which contains the velocity and pressure map (all_results_00*).

I saw in this post:

that the “Lagrangian Surface helper” and “Lagrangian Seed helper” filters allow respectively to define the properties of the surfaces and the particle source used in the Lagrangian tracking. So I applied these 2 filters.

Then, when I try to use the “Lagrangian Particle Tracker”, I have to select 3 inputs:

  1. Flow Input
  2. Particle Seeds
  3. Surface

In the window that opens, I manage to select the “Flow Input” (= all_results_00*) and the “Surface” (= LagrangianSurfaceHelper1), but I can’t click on “LagrangianSeedHelper1” for the “Particle Seeds” parameter.

How to do it?

Did you generate the needed data in the LagrangianSeedHelper ?

I suppose you are using the Matida Integration Model ? It requires the seed to have some values associated to it.

I do use the Matida Integration Model.
Thanks a lot for the solution, I had indeed left some parameters of the LagargianSeedHelper “unchecked”!

1 Like