Lighting not disabled for slice representation

Contradictory to the release notes of version 5.6,

Lighting on the Slice representation had the undesirable effect of darkening the slice with the default light, which is off center with respect to the view and focal points. We assume the common use case for this representation is to view the data as directly as possible to match colors on the slice with colors in the color legend. To better support this use case, lighting is disabled for this representation.

lighting is not disabled for slices in version 5.6 and 5.7.

Steps to reproduce the issue:

  • Sources > FastUniformGrid
  • Add Slice, apply


You will notice that the shade of blue changes depending on the viewing angle although it is supposed to represent the one blue associated with the value that is visualized on the slice.

I know that I can turn off lighting globally by dropping the following lines into the python console,

RenderView1 = GetRenderView() 
RenderView1.UseLight = 0

but this is not helpful in situations with both, 3d surfaces and slices.

I really need to be able to have lighting turned on for contour surfaces while it being turned off for slices. Does anyone know a workaround?

You are using the Slice filter to produce a slice. That surface is indeed still intended to be lit as it is a 3D object in space.

The Slice representation (available in the dropdown menu in the toolbar) is the slice representation that has lighting disabled.

To disable lighting on the output of the Slice filter as you have produced it, you can set the Diffuse lighting term to 0 and the Ambient lighting term to 1 in the Lighting section of the Display properties in the Properties Panel.


Okay I see, so to be able to view multiple slices I will have to add multiple ExtractSubset filters and switch the representation of each one of them to Slice.

On the other hand there is still no way of obtaining a non-lit slice that is not aligned with the coordinate system.

From my point of view it would make more sense to add a “Turn-Off-Lighting”-checkbox to the properties-tab of any object.

See the last paragraph in my first response. It is possible, it just takes two steps instead of one :slight_smile:

:relieved: oops
Thank you Cory! I’m sure your response will be helpful to others too.