Load data groups

I have a request regarding the features in Paraview. Instead of asking for new features, I would like to express my appreciation if you could bring back some of the previous features. Specifically, I found the ability to directly group a series of files with the same title header extremely helpful in Paraview 4.4.0. It allowed me to conveniently handle all the files together and easily generate animations. However, I have noticed that this feature is missing in the newer versions of Paraview. I have attempted to group the files myself, but unfortunately, I have not been successful. Since I’m not well-versed in Python, I’m unsure how to achieve the same functionality. Therefore, I kindly request your assistance in addressing this issue. Thank you in advance for your support.

Do you mean a time series ? This is currently supported.

Yes. More exactly, in Paraview version 4.4.0, it was possible to load a group of files, such as “data_0.csv” … to “data_50.csv”, and the loaded files would automatically form a combined group named “data_*.csv”. This feature allowed for easy handling of the files as a cohesive unit, enabling smooth generation of animations. I assumed that this functionality would also be available in newer versions, like the latest 5.11.0. However, I have been unable to locate this specific setup in the newer versions. If there is an option or alternative in the latest version that resembles this functionality, I would greatly appreciate it if you could provide some guidance or explanation. Thank you very much

It is available, I’ve moved you thread to support. Please share the file that do not show this behavior.

example.zip (1.7 MB)
Many thanks.

I have sent one example that worked in 4.4.0 but did not work in 5.11.0.

Works perfectly in ParaView 5.11.1:

Dear Mathieu,

Thank you for testing this out. It is the status that I expected to load. I tested the data myself by placing it in the Desktop folder and it worked perfectly. The strange thing is that I couldn’t load the data as a group in its original folder location, possibly due to the folder naming format. Nevertheless, I’m relieved that it works now. Thank you once again.