Looking for a feature: "invisible" for selection?

Not sure if I am just blind or the feature does not exist!?

What I mean: You have two graphic “items” in the pipeline which you show in a render view. Now you want to select cells or points in one of the two, but not in the other, so it would be helpful if for the “other” you could turn off the “selectibility” - first of all if it is huge!

Of course you could turn off “the other”, but maybe you need it for orientation purposes during the selection.

I could have sworn there was a “selectable” checkbox a while ago – maybe in old OpenGL backend days. Feel free to report an issue, it should be easy to implement.

Thanks for quick reply!

Is it really an “issue”? I would say it would rather be a “feature request”!

(Because ParaView is also not making coffee for me, but I would not really consider that an “issue”! :slight_smile: )

same thing really :), the issue tracker calls all bugs and features as issues.

Ok, I entered it:


Would be really helpful in some cases like selecting some parts of a model that have to be above a triangulated topo surface which in turn should not interfere with that selection process.

Under the Display properties (in the Miscellaneous group) there is an advanced option named Pickable. It is easiest to find by just searching for “pickable” in the search box on the top. I believe that is exactly what you are looking for.

Ah! That’s what it’s called. I knew it was there but I kept looking for Selectable :slight_smile:

Yes, it’s a bad name. Perhaps someone should raise an issue to change it.

Thanks a lot for finding this option for me!

But regarding the naming: If you change it to “selectable” there will certainly be another one desperately searching for the “pickable” option…

Conclusion: For me the “issue” is now solved with this.

I think “selectable” is the right name for this option. The user-facing name for the feature is selection. All of the controls regarding finding points/cells based on rendered location are labeled with selection (with the exception of this one). “Picking” refers to a specific operation that happens internally in ParaView. (Specifically, it means you do a special “pick” render that writes cell/point ids to the image.) I’m sure that’s how this label got its name, but the name should really match the rest of the ParaView GUI and its documentation.