LS-DYNA can't read multiple d3plots

I ran this SPH example in LS-DYNA ( and it generated the d3plotxx outputs.

I was able to read into Paraview the .k LS-DYNA keyword file and it created the associated .lsdyna XML file and was able to read the first d3plot file, but not any of the subsequent others.

I am able to post-process the run without issue using both LS-PrePost and also Hyperview.

I am interested in wanting to post-process this run in Paraview because I recently learned about Paraview via DualSPHysics and I want to be able to compare the results from the LS-DYNA run agains the results from DualSPHysics.

The specific error that I get is that when it tries to open d3plot01, Paraview says that it doesn’t recognize the data/format and wants me to select the appropriate reader.

And this is true regardless of whether I set the file type to LS-DYNA when I open the file or not.

I’ve also tried to rename all of the d3plotxx files to d3plotxx.d3plot to see if that would help and it didn’t.

Any suggestions/advice would be greatly appreciated.

Thank you.