Matplotlib conflict

Hello there, could someone help me to fix a problem related with the version of matplotlib that ParaView installed in my ubuntu machine? I have installed paraview using sudo command, and when i tried to run another code that uses matplotlib, it’s always appearing:

UserWarning: Unable to import Axes3D. This may be due to multiple versions of Matplotlib being installed (e.g. as a system package and as a pip package). As a result, the 3D projection is not available.
warnings.warn("Unable to import Axes3D. This may be due to multiple versions of "

And i have the 3.8.2 version that i installed using pip. As the version of matplotlib installed by ParaView is 3.5, it’s causing the conflict of versions and i’m having problems to plot graphs and I also cannot plot 3d plots. What should I do to fix it?

How did you install ParaView (sudo just raises privileges)? What package did you install?

I would recommend not installing official packages with sudo and instead just extracting the tarball somewhere without root access and running from there.

I followed the commands from this website:

When I tried to install from website downloading, it didn’t work to install it from terminal (And I don’t know how to do it exactly, but what I tried, it didn’t work.)
I’ll try again to install it from website

Oh, if you installed the apt package, then that is not Kitware’s package. If there’s a matplotlib embedded in there, it’s a problem with the Ubuntu package.