Missing DLL

I have installed paraview 5.8.0 on my laptop running windows 10. When I try to run it I get a System Error. The code execution canot procedd because VCOMP140.DLL was not found. Any ideas?

VCOMP140 is the visual studio 2015 runtime library. Anything compiled with that version of visual studio needs to include it so that users who do not have visual studio installed can run the application. If that is not present, then there is a regression in our binary release process. @ben.boeckel @cory.quammen please keep an eye on it.

Christopher, in the meantime a workaround for you in the meantime is to download and install the DLL from Microsoft. Visual C++ Redistributable for Visual Studio 2015 from https://www.microsoft.com/en-ca/download/details.aspx?id=48145.

ParaView 5.8.0 ships with vcruntime140.dll but not VCOMP140.dll. VCOMP140.dll is a redistributable needed for OpenMP [1], which we apparently need.

[1] https://docs.microsoft.com/en-us/cpp/windows/determining-which-dlls-to-redistribute?view=vs-2019

I created an issue to track this at https://gitlab.kitware.com/paraview/paraview/issues/19717.

Thank you-worked great!

This worked. Thanks chris