Missing Elements In Large Exodus Files

I’m seeing a problem where elements are just “missing” when viewing really large Exodus / Nemesis results.

The problem seems to happen with any mesh / result with over 100M elements in it. Both 2D and 3D.

For instance, here is a 2D result showing the problem:

It’s also shown here in this 3D result… essentially the elements are just “missing” around those red “tubes” in this model. (they are missing in other parts of the model as well… but this is the easiest place to see them):

Both of these the meshes are over 100M elements.

In both cases Paraview reports the correct total number of elments in the information box.

I should also mention that Exodus files generated from this same code look just fine as long as they are a bit smaller…

1 Like

A bit more info: I can repeat this on multiple machines… all with Paraview 5.6 (haven’t tried older Paraview yet).

One more note: I can view the “missing” elements if I only view those element blocks. So they are there and well formed within the Exodus file.

It sounds like you might be running out of GPU RAM.


On one of the machines I’m running dual Quadro P6000 graphics cards in SLI with 24GB of RAM each (I think this is pretty much the biggest card NVIDIA makes right now).

On the other machine it’s dual Quadro K6000 in SLI with 12GB of RAM each.

The interesting thing is that they both draw about the same amount of the elements. (i.e. if I load the same solution / mesh file the amount of missing elements is similar on the two machines).

Is there a quick way for me to determine if I’m running out of GPU RAM?

I should also mention that this is in Linux. One machine is fairly modern Suse the other is brand new Ubuntu.

I have checked the video memory usage (using the Nvidia control panel) while I have these models open… and it’s not even close to being full.

Is there something else you can think of for me to try?

If I put one of these large results up on Dropbox or something would someone be willing to try to load it?

BTW: We hand-compiled a version of the latest Paraview here… and it still has the same problem.

One interesting bit: the elements REALLY are there - they are just not being displayed. If I slice the model in half, for instance, using a filter… then all the elements that didn’t show up before do show up in the slice.

It really feels like there is some sort of hard limit on the number of elements Paraview can draw or something…

Maybe this is a limitation of OpenGL (somehow) rather than a fundamental limitation of your hardware? Maybe the OpenGL rendering is limited to 32-bit integers that are overflowing?

One thing to try is to turn on OSPRay rendering. That is a totally different rendering system that does not use the GPU at all. That’s not a great solution for you since I’m sure you want to use your beefy GPU hardware, but it could help narrow down the problem. If you don’t see the same behavior in OSPRay, then the problem is most likely in the rendering. If you do see the same behavior, the problem is most likely somewhere else in ParaView.

1 Like

I am probably wrong, but this looks like stitching to me. Could it be that you are drawing your data at exactly the same depth as another surface? Could you either turn off blocks to see your data, or select - and hide - one surface, to see the other?

As a side note, you may want to try a different color map. the one you have chosen is not linear (i.e. Rainbow). Try using Jet or Rainbow Uniform. There may be information hidden in those fields of green!