Nek5000 file format


I am trying to use Paraview for output visualization from Nek5000. I have run some examples from Nek5000 on my univeristy’s HPC cluster. Since the example is small, I can copy the results to my desktop and view it using Paraview 5.6.0 installed on my desktop. On the file formats, I can see the .nek5000 file extension and it will successfully display the results. However, I have also installed Paraview into my home directory on the cluster. It built successfully (superbuild). I can get an interactive session on a node and start pvserver, create an SSH tunnel from my desktop to that node and successfully connect with my desktop Paraview client to the pvserver. If I choose, File -> Open, I can see my files and folders on the cluster, however, the .nek5000 extension is not an option in the File Type drop down list. If I try to view all file types (*) and select the sample.nek5000 metadata file, since Paraview does not recognize the format, it asks me to select a Reader. But there is not a Nek5000 option.

Why is there a difference between running it locally and selecting local files versus connecting to the pvserver on the cluster?


Hi Chris, welcome to the ParaView community.

the Nek5000 Reader is actually part of VisIt. The release of ParaView that you are using locally, is built with VisIt which enables you to use the Nek5000 reader.

ParaView (and pvserver) on the server on the other hand, have probably been built by your system administrator, without this option, so it does not provide access to the .Nek5000 reader.

You have two options :

  • Ask your system administrator to rebuild ParaView with the PARAVIEW_ENABLE_VISITBRIDGE=ON cmake option.
  • Download the ParaView release in your user folder in the server and run its pvserver instead of the one installed in your server.

Hope this helps.

1 Like

Hi Mathieu,

Sorry for the delayed reply as I have been traveling.

I am building my own using the superbuild and specifying v5.6.0 following the instructions here:

If I try to build it with the option you have suggested, I get an error:

$ cmake -DPARAVIEW_ENABLE_VISITBRIDGE=ON …/paraview-superbuild/
– The C compiler identification is GNU 4.8.5
– The CXX compiler identification is GNU 4.8.5
– Check for working C compiler: /usr/bin/cc

CMake Warning:
Manually-specified variables were not used by the project:

If I just run “cmake …/paraview-superbuild” (which completes fine), then I can see a file generated at ./build/superbuild/sb-paraview-configure.cmake, which contains a command like this:


How do I set this flag correctly for the superbuild?


PARAVIEW_ENABLE_VISITBRIDGE is a ParaView cmake option.

For the superbuild, it should be : ENABLE_visitbridge