NetCDF file gives error "Incorrect Dimensionality"


I generated some NetCDF files using FloPy (flopy3_export.ipynb) and tried to import and view these in ParaView, but I get an ‘Incorrect Dimensionality’ error for every single file NetCDF (.nc) file.

Any ideas what might be causing this error or any tips on how I might be able to troubleshoot it?


Hi @datathing ,

Today I stumbled over your post, since i had the same Error for my netcdf-data (Paraview 5.6.0)

What helped on my side, was to use the filter ImageDatatoPointSet, and after that I can visualize my data correctly.

Unfortunately, I cannot exactly locate, where/why the error occurs, since I tried to manipulate the data with certain attributes (axis, cordinates, featureType,…) but the error persits.

I also attached a short example on how I created the data ( (697 Bytes)) and the data itself ( (664 Bytes)) for others to see and test, or maybe give a hint on what is wrong/missing in the dataset.

So far, I have only worked with netCDF containing planes or volumes. But I have noticed that ParaView requires a specific order of the data. In my case I need to apply permutations for a correct visualization. In your case it may be that the 1D case is not supported…?