When I import my NetCDF file in Paraview, only the variables names followed by “_units” are available. I’d like to see the variables results. Have you any idea please ?
Thanks in advance, Frank

please share your file


Thanks for you short answer, I used the Paraview installed with BlueCDF (5.4) and it works. I don’t know if it’s related to BlueCDF or just the version. The Reader name is also different.

Best regards, Frank

@Kenneth_Moreland : Do you know if this issue has been logged and what is the status ?

Thanks !

Didn’t we just hash this out on this post?

To back up a step, it’s important to note that the netCDF file format is not really a file format from the perspective of ParaView or other data consumers. NetCDF really just holds a collection of multi-dimensional arrays with attributes like a name. That alone is not enough for a ParaView reader to just know how to read the data.

So simply saying “I have a netCDF file” is not sufficient information for ParaView to read it. That’s like saying “I have an ASCII file.” That could mean lots of different things. You need to specify a convention of how the data are arranged. For example, an ASCII file could be a table with delimiters (i.e. csv) or a hierarchy with tags describing polygonal data (vtp). Thankfully, different ASCII file producers with different conventions tend to understand are each a format in its own right and identify the file as such. It kind of drives me nuts that so many netCDF producers don’t recognize this fact and just write out files with a .nc extension and expect consumers to magically understand what they mean.

Because there is this ambiguity on the format of data in netCDF files, there are many different netCDF readers to handle the different known conventions. So simply sending a screenshot is usually not enough information to determine what is going on. We usually need to have an example file or at a minimum the output of ncdump -h.

That said, on the previous post I thought we determined that the appropriate reader was the CDI reader (available through a plugin). That reader is maintained by DKRZ and you would have to go through them for help with this reader. @Niklas already reached out to you and offered help. What happened with that?

1 Like

Thanks @Kenneth_Moreland . I’m only wondering if there is some kind of regression in ParaView, where a dataset previously readable is not readable anymore with ParaView 5.9.1.

Not to my knowledge. I think the difference is that @frank_forster used different readers in the 2 versions of ParaView (CDI Reader in the older version, netCDF/CF in the new version).

1 Like

Hello @mwestphal and @Kenneth_Moreland,
I’m using the NetCDF reader in both 5.8 & 5.9.
The CDI Reader crashes ParaView when clicking on “Apply” in both version.

So far I’m using 5.8 due to that problem.
But I realised that PV crashes when I change the Time step with 5.8.

To recap :
PV 5.9 can’t read components, it reads the “_units” instead of content
PV 5.8 Can’t change Time step (crash)

I tried with 5.4 and I have none of these bugs but I don’t think it’s a long term solution.

@mwestphal I GoogleDrived you the .nc because it’s too big for WT.

Best, Frank

This is a @Niklas question :slight_smile:

I already tried to get in touch with Frank using a direct message here, and as written in the other post, the CDI reader that is available in the official ParaView version at the moment only supports ICON netCDF data. In our new, not merged version, we support also grib compressed data and a number of other unstructured weather/climate models. With other data the likelihood of a crash is quite high. Therefore @frank_forster and anybody who has difficulties in using the CDI Reader with ICON data, please get in touch with me at Thanks