Not able to load 3D volume of Dicom Dataset

Hi,

We are new to Paraview but our team has some experience working with other softwares like 3D Slicer, Pyvista, etc.
I wanted to try Paraview which looks like an easy to use and very helpful tool for our visualization purpose of medical data.
I am using linux centos(3.10.0-1160.11.1.el7.x86_64) and Paraview v5.9 for linux.

When I downloaded and opened Paraview it gave me this Warning(attached in 2nd screenshot).
Then we ran this command before starting Paraview, and this time there was no error. Worked I guess.

export MESA_GL_VERSION_OVERRIDE=4.6
Then I tried loading my Dicom dataset from local machine as given in this documentation: 2. Loading Data — ParaView Documentation 5.8.1 documentation

The data we believe was successfully loaded as we could see the some metadata about the dicom data in the “Information” tab on the left, like the range of pixel values, dimensions of each axes, etc, which were accurate.

But them when we tried to load the 3D view of the data selecting “Volumes” and clicking the “eye” icon next to the loaded directory. We got this error:

ERROR: In /builds/gitlab-kitware-sciviz-ci/build/superbuild/paraview/src/VTK/Rendering/VolumeOpenGL2/vtkVolumeTexture.cxx, line 932
vtkVolumeTexture (0x1b52f090): Capabilities check via proxy texture 3D allocation failed!

ERROR: In /builds/gitlab-kitware-sciviz-ci/build/superbuild/paraview/src/VTK/Rendering/OpenGL2/vtkTextureObject.cxx, line 1454
vtkTextureObject (0x1b539a80): Failed to determine texture parameters. IF=0 F=6403 T=5126

ERROR: In /builds/gitlab-kitware-sciviz-ci/build/superbuild/paraview/src/VTK/Rendering/OpenGL2/vtkTextureObject.cxx, line 1454
vtkTextureObject (0x1b5396f0): Failed to determine texture parameters. IF=0 F=6407 T=5126

ERROR: In /builds/gitlab-kitware-sciviz-ci/build/superbuild/paraview/src/VTK/Rendering/OpenGL2/vtkTextureObject.cxx, line 1454
vtkTextureObject (0x1bb24380): Failed to determine texture parameters. IF=0 F=6403 T=5126

We wanted to understand what’s wrong here, why the data is not able to load into a 3D view.
Any help or suggestions would be highly appreciated. We are also attaching out GPU information in the 1st screenshot.

Thanks,
Pranay