Not all elements are displayed

Dear all,

I have a relatively large surface mesh, with 36M triangles (18M nodes), stored either as a .vtm or .ex2 file (same issue in both cases). There are 46 blocks.
I can load both files but only some of the triangles are displayed (I believe entire blocks are missing). However, the missing blocks appear when I interact with the view.
I have the same issue with Paraview 5.6, 5.7 and 5.8
Is there a setting I am missing?
Best regards,


No clue. Sounds like a bad dataset. Could you make a much simpler dataset, say 3 blocks, and then post it here?

A work around is to disable LOD in the settings.

I agree with @wascott, probably a bad dataset, please share a small part of it that still shows this behavior.

F22.ex2 (1.2 MB) Thank you both for your responses.

I tried generating a toy dataset with the same procedure, but I cannot see the same issue with it (it is attached just in case - there are plenty of geometric problems such as non connected surfaces or double surfaces, but it loads OK). I am sorry I cannot share the full geometry.

I tried to investigate a bit more the issue I am seeing:

  • It does not appear when I load the same file on Linux (either with v5.4 from debian or with v5.8 from the Paraview website)
  • On OSX (with all thee versions mentioned in my previous post), I tried loading only selected blocks. It seems the issue appears when the number of elements exceeds a certain threshold (somewhere 33.4 and 33.6 million triangles), independently on which blocks are loaded.
    If I deactivate LOD, then surfaces are missing both when I interact with the view and when I don’t.

You need to set the threshold to a high number, not 0.