Not responding when using pvpython

Hello, I have been following this guide:
I’m using my Microsoft Surface Pro 9 running Windows 11. When I use the pvpython in the terminal to create the sphere, a pop window appears but it stops responding as follows. Do you know what might be the problem? When I use the application it works fine but when I use the python shell it stops responding. I can continue to write commands but it stops responding and executing.

This is expected behavior, use Interact() if you want an interactive window

The issue is, it just get stuck on the first render and when I create the filter and render it, nothing happens. It is still stuck on the first pop up window. The values are changing but the screen is stuck on the image I shown.

Do you call Render() again ?

Yes, it gets changed when I call interact() but shouldn’t the view get updated when I call Render() ?

Yes I should, is it not ?

Yes, it doesn’t get updated

I just tried the following with ParaView 5.12.0 Binary release, it works great.

from paraview.simple import *

I’ve tried it and I’m still having the same issue.

Which version of ParaView are you using ? where did you download it or did you compile it ?

This is the version I’m using ParaView-5.12.0-Windows-Python3.10-msvc2017-AMD64. I downloaded it from the paraview website.

Ok, Ill need to check on Windows then.