Numpad keys not working with 5.9.0 RC1

Since no one else complains about it, this might be system specific. I am unable to type in numbers from the numeric keyboard in 5.9.0 RC1. I can imagine that this is related to the new Qt that comes with Paraview (I am using the Linux binaries from Kitware). I have no such issues in Paraview 5.6.0 and other programs. I found some Qt bug reports on this

but I am not missing the devel libraries.

My OS:

@ben.boeckel: Any idea for this one ? it may be related to a missing libxbcommon-x11-dev.

The CI image has libxkbcommon-devel installed, so we build our Qt with it installed. It might be needed on the client though (it was added to the test CI image mid-November).

The 5.9.0 RC1 binaries are from the beginning of November (06.11). Could that be the issue? I do have libxkbcommon-devel installed but perhaps there is some version mismatch or other conflict.

Can you try with the RC2 ?

Unfortunately it’s the same problem with the RC2.

Is there any output on the terminal if you run it from there?

no, nothing on the terminal

I had the same problem, and I am using:

Distributor ID: Ubuntu
Description: Ubuntu 20.04.1 LTS
Release: 20.04
Codename: focal
Kernel release: 5.8.0-34-generic
Kernel version: #37~20.04.2-Ubuntu SMP Thu Dec 17 14:53:00 UTC 2020

Hrm. There’s got to be some plugin missing or something. I don’t see anything relevant though :confused: .

Reported here:

FYI, I’m experiencing the same issue on Debian Buster (ParaView 5.9.0).

I am also experiencing the same problem with the final 5.9.0 release on Ubuntu 18.04. Unfortunately, installing both libxkbcommon-dev and libxkbcommon-x11-dev does not resolve the issue. However, one thing I have noticed, which I hope is of potential interest, is that, irrelevant of the NumPad being activated or not, pressing the keys while maintaining Shift yields expected values.

Interesting. I have just tried holding Shift and I need to keep NumLock off to enter numbers. With NumLock on it still doesn’t work for me, even when holding Shift.

Some further testing. With NumLock off ‘5’ always works, but the other digits need Shift. With NumLock on ‘5’ works only with Shift, the other digits never work.

1 Like

Thank you for mentioning shift key. It works for me. But still have the same issue with fresh downloading paraview5.9.0 on kubuntu 20.04

Best regards

This issue was finally tracked down to not having xkbcommon-x11-devel in the build image we were using. Unfortunately, Qt is silent about such problems. The fix will be included in 5.9.1.