Nvidia Index volume rendering problem

Dear All,
nsd-1.vtu (1.8 MB)
The Nvidia Index plugin volume rendering incorrect result compared to paraview volume rendering. Both the images are shown below. I have also attached the vtu file too to reproduce the image.


Welcome to ParaView, Palas. What is the version of ParaView where you are seeing this?

Thanks Cory. This is Paraview 5.8.0. I am using Ubuntu 20.04

This is output in terminal when
VisRTX 0.1.6, using devices:
0: GeForce GTX 1650 (Total: 4.1 GB, Available: 4.0 GB)

when I load plugin

vindex: 1.0 INDEX main info : NVIDIA driver version: NVIDIA UNIX x86_64 Kernel Module 440.100 Fri May 29 08:45:51 UTC 2020
nvindex: 1.0 INDEX main info : CUDA runtime version: 10.2

Full output is attached in this txt file after I load the plugin and apply the filter etc.

output_terminal.txt (8.7 KB)

I tried in windows 10 too, same problem, changed the data type to float in vtu file (to remove the double to float warning) but all in vain.

Let me know if you need more information.


Thanks for the information. You may wish to reach out to NVIDIA for assistance at paraview-plugin-support@nvidia.com.

Thanks Cory. I have mailed them.

Hi Palas,

Please can you post a solution if you get one from nvidia.

Ok Kyle, I will. They have responded and looking into the problem.

I encountered a similar problem. After applying CellData to PointData, save the result in a pvd file and then open the pvd file and select IndeX representation. This trick worked for me.
Thanks to Joerg Mensman from the Nvidia IndeX team for suggesting this.

Thanks, Alankar. I tried but it didn’t work for me.

Below is the result using your trick.

Bump: also having this issue, also using “Cell data to point data”, on Paraview 5.8


The latest versions of Paraview don’t have this issue. You can try it there.


Hi Palas,

Thanks! I only have Paraview 5.8 installed on my visualisation cluster – sounds like this is a good reason to request 5.9.

1 Like