nvindex error when axes enabled

volume rendering a structured grid using representation “nvidia index” i get:

vtkOutputWindow.cxx:76 ERRI nvindex: 1.0 PVPLN main error: Trying to set unsupported z-buffer precision 0.  Please verify the status of the X-server when the precision is reported as 0.

when the “data axes grid” or “axes grid” box is checked. performance then drops massively (fps drops from >200 to <10) relative to no-axes.

when representation is “volume” i don’t have this error message but the performance still drops (a lot but not as much) with axes on.

my nvidia card is a 2060s…i get “vtkOutputWindow.cxx:86 … datasets in double format are not natively supported…will convert with corresponding overhead…” if i save my data in double format. that goes away when i save as single. this is fine and as expected. but this axes thing cuts performance way more than even that on-the-fly conversion does.

StructuredGrid can’t be represented with the NVidia Index representation.
I assume that you are converting to ImageData or UnstructuredGrid ?

I can’t reproduce with either of them. (ArchLinux, ParaView 5.8.0, 1050 Ti, 440.59)

Please state :
Version of ParaView ? Where from ?
OS ?
GPU driver ?

Please share your dataset if you can.

Resample to image data, yes. Sorry didnt realize that mattered (new to paraview).

Ubuntu 18.04 ,5.8.0, 2060s, 440.59

I’ll see if I can get a dataset that is shareable…

Did you download ParaView from : https://www.paraview.org/download/ ?

I tried with this image dataset. I do have the double warning, but the FPS is quite high, even with the Axes.

index.vti (541.8 KB)

my paraview is from there yes.

and ok ill try this data set later today and come back.

the only difference is the clicked axes box. that fps drop is pretty consistent if i rotate the model etc.

what other settings would you like to see?

My bad, I reproduce and the FPS drop is quite visible !

This is a known issue, see here :

We hope to fix it for 5.9.0.

Ok fair enough and thanks Will look out for it.

so i’ve just retried this on 5.9rc2 and rc4…it crashes both with and without the nv plugin activated before i even get to toggling the axes setting.

runs in 5.9 but axes issue still present.

Well, the issue has not been closed so it is expected. It is now targeting 5.10.

1 Like

One possible side effect is that the screenshot shows a small number of white (transparent?) pixels, in both volume and nvindex representations.