Off-screen MESA freezes for a large mesh


I have a fairly large 3D mesh O(0.5B) cells in OpenFOAM and ParaView server built with superbuild with off-screen Mesa and another version built without superbuild with EGL-GPU rendering. When opening the mesh with OSMesa server I experience a freeze after the distributed data load, whereas the EGL/GPU version works fine.

At the moment the data is decomposed into 64 sub-domains. I tried to open it with 4 rank server and 64 rank server. Both experienced a freeze though when in outline mode, I was able to at least see and rotate the outline - the freeze happened only after I switched to surface. The small tutorial cases of OpenFOAM worked fine.

Could you suggest how I could debug this problem?

OSMesa paraview was built with flags I cited here.

Can you try with the binary release from

Hmm, I could never get the distributed binaries work for parallel servers. In this case I get mpich error like this?

[mpiexec@sqg7b20.bullx] match_arg (utils/args/args.c:160): unrecognized argument mca
[mpiexec@sqg7b20.bullx] HYDU_parse_array (utils/args/args.c:175): argument matching returned error
[mpiexec@sqg7b20.bullx] parse_args (ui/mpich/utils.c:1603): error parsing input array
[mpiexec@sqg7b20.bullx] HYD_uii_mpx_get_parameters (ui/mpich/utils.c:1655): unable to parse user arguments
[mpiexec@sqg7b20.bullx] main (ui/mpich/mpiexec.c:128): error parsing parameters

The cluster in question has OpenMPI and Intel MPI. Is there a way to combine without rebuilding ParaView?

You should either use the MPICH provided inside ParaView binary or using your own Intel MPI by using the MPICH compatibility: Leveraging MPICH ABI compatibility for distributed binaries

1 Like

This is great, thanks a lot. May save me a heck of a lot of time in the future. Got it to work with Intel MPI, and --system-mpi switch.

Unfortunately it still freezes when switching to surface. On the client side I see “GeometryRepresentationWithFaces (100%)” and no progress after this. I’ve tried a small clip to select a subregion, but same thing happened.

Could you share the data to reproduce ?

Yes, I have a mesh which I could share, but it will be circa 32GB and I think it’s already binary so I won’t be able to compress it by a lot. I could probably send it to you via Box, but if you have an FTP server or another way that may be faster.

If you’re happy to rerun snappyHexMesh I can just send the generation steps.

I’m afraid not. 32Gb is a bit much indeed.

Turns out I was wrong about the size as I’ve used an uncompressed format. After compression the case is 10GB. Still large. I have just sent you the file via Box. It may ask you to create an account, but you should be able to select free plan. If it doesn’t work, please let me know and I generate a temporary public link.