On Fedora, I can't see or find filters in the Alphabetical list!

There is (probably) an issue between Qt and ParaView using the fedora provided ParaView 5.8.0 package.

A simple work around is to enable this setting :
Edit -> Settings -> Toggle Advanced Properties (the Gear Symbol) -> General Options -> Force Single Column Menu

More info here : https://gitlab.kitware.com/paraview/paraview/-/issues/19896