Open data with.. not appearing when using Paraview server

When I open the XDMF file locally on my machine, there is always “open data with…” option to choose the reader. However, it does not appear when I use Paraview server. Is there a way to change the reader ?

please share your data and version of ParaView you are using.

And, because I have seen this before, try Edit/ Reset to Default Settings. Under some weird conditions, I have seen ParaVeiw “remember” that the Open dialog is offscreen. Note I believe the developers blocked this case, but it doesn’t hurt to try…