open .vtk file

Dear Paraview Support,
Paraview 5.6 was running ok on my Windows10 laptop, but I tried to update to 5.8 and I no longer can read my .vtk files. I get an error message saying
" A reader for “my:file.vtk” file cannot be found. Please choose one:…"
and there is a long list of readers. I could not find any that work.
I went back to my former version of Paraview 5.6 (or even earlier versions) but I get the same error.
How can I open my standard .vtk files (which were working fine beforehand)?
Many thanks for your help,

Hi Luca, I haven’t used .vtk files in some time, but I just tried loading the wavelet source, saving the data as a vtk file, deleting the source and loading the vtk file I had just produced. That worked for me. If you can share your vtk file somehow, I’d be happy to try and load yours. I don’t have a windows box, but I can test on linux and mac. So either the windows build is broken or perhaps your vtk file was injured somehow?

Hi John,
Thank you very much for your reply.
I attach below a couple of .vtk files that I need to read in Paraview.
(They are snapshots at increasing times, I have a few hundreds of them and before I was reading all of them in Paraview and make a movie with Save Animation.)
Could you please try to open these two files in Paraview? Many thanks,

u0005.vtk (1.53 MB)

u0010.vtk (1.53 MB)

I can validate that ParaView 5.8.0 and 5.8.1 on linux is not opening these files. I’ll look a bit closer.
I also noted that my previous experiment gave me a warning when I opened the vtk file produced with 5.8.1 in 5.8.0, so something newish has happened since I last looked at legacy VTK files closely.

Warning: In /home/buildslave/dashboards/buildbot/paraview-pvbinsdash-linux-shared-release_superbuild/build/superbuild/paraview/src/VTK/IO/Legacy/vtkDataReader.cxx, line 564
vtkStructuredPointsReader (0x7b9afe0): Reading file version: 5.1 with older reader version 5.0

I would not expect your files to be read based on my experience. The first line should be ascii text that defines the version as per the file-formats.pdf vtk bible. Your first line appears to be binary, the one i created appears to be correct:

patchett@ganymede:~/Downloads$ head -n1 u0005.vtk
M�*�;��yoS …
patchett@ganymede:~/Downloads$ head -n1 ~/Desktop/deleteme.vtk
# vtk DataFile Version 5.1

try loading mine:
deleteme.vtk (36.4 KB)

Hi John,
You are absolutely right, my files have been corrupted somehow. I compared my files with older versions which work and as you say they do not start with the ascii text that defines the version. Thank you for pointing that out and sorry for not having checked my files beforehand!
I will go back and generate my vtk files correctly. Thanks again,

1 Like