OptiX does not show up

Hi there,
I am using ParaView-5.8.0-MPI-Linux-Python3.7-64bit binary release on CentOS 7 with
./mpiexec ./paraview. The machine has one RTX 2080Ti, Driver 440.44, CUDA 10.2:
But when I enable ray tracing OptiX backend is not available.
Did I miss any steps? Or should I build from source? Thanks!

./mpiexec ./paraview.
There is no reason to run paraview with mpiexec. But it is unrelated to your issue.

Do you see the RTX detected in the terminal. Something like :

$ ./bin/paraview
VisRTX 0.1.6, using devices:
 0: GeForce GTX 1050 Ti (Total: 4.2 GB, Available: 4.1 GB)

Thank you for your reply.
I am using binary release and mpiexec in the system is not compatible with that.
When I run paraview, no info pops up:

$ ./mpiexec ./paraview

Just run

$ ./paraview


$ ./mpiexec ./paraview

is not necessary. mpiexec might be needed if you want to run pvserver, the ParaView server component, in parallel. But it is definitely not needed for paraview.

The problem is I cannot execute paraview mpi binary directly:

Abort(2140047) on node 0 (rank 0 in comm 0): Fatal error in PMPI_Init: Other MPI error, error stack:
$ mpiexec --version
pbs_version = 19.1.3
$ mpirun --version
mpirun (Open MPI) 3.1.3

Note - you can download non MPI binaries too, but I agree with Mathieu that use of MPI shouldn’t be related.

You shouldn’t have to build from source either, but it would be a way to diagnose. Then you can step through the GPU detection code path here and here to see whether a library is not being found or whether the wrong GPU is being detected.

One quick thing to do is to use system settings to force use of the discrete graphics card. That could be the problem I suppose if the integrated GPU is being queried rather than the discrete one.

Finally, perhaps @tbiedert has other suggestions about what might be wrong.

I tried to compile from scratch but encountered too many problems. Then I tried to install Optix 7.0 but it still didn’t work. Finally I installed Optix 6.0 and export its lib to LD_LIBRARIY_PATH and now optix shows up in paraview! Thank you guys!