ParaView 5.6.0 crash when loading raw binary file

(Jarno van der Kolk) #1

Hi all,

I am using ParaView-5.6.0-MPI-Linux-64bit that I downloaded from paraview.org. I have a binary file of 16 x 16 x 16 floats in little endian that I try to load in ParaView using “Image Reader”. I then use:

  • Data Scalar Type: float
  • Data Byte Order: LittleEndian
  • Data Origin 0 0 0
  • Data Spacing 1 1 1
  • Number Of Scalar Components: 1
  • File Lower Left: true
  • Scalar Array Name: density
  • File DImensionality: 3
  • Data Extent:
    • 0 0
    • 0 0
    • 0 0

I then get the following crash message in the terminal:

Generic Warning: In /home/buildslave/dashboards/buildbot/paraview-pvbinsdash-linux-shared-release_superbuild/build/
superbuild/paraview/src/VTK/Parallel/MPI/vtkMPICommunicator.cxx, line 71
MPI had an error
------------------------------------------------
Invalid argument, error stack:
MPI_Type_create_subarray(344): MPI_Type_create_subarray(ndims=3, array_of_sizes=0x7fff1d1aeca0, array_of_subsizes=0
x7fff1d1aecb0, array_of_starts=0x7fff1d1aecc0, order=57, MPI_BYTE, newtype=0x7fff1d1aec98) failed
MPI_Type_create_subarray(127): Argument array_of_starts has value 4 but must be within [0,0]
------------------------------------------------

application called MPI_Abort(MPI_COMM_WORLD, 873079820) - process 0
[unset]: write_line error; fd=-1 buf=:cmd=abort exitcode=873079820
:
system msg for write_line failure : Bad file descriptor

I have included the raw binary file:
simpleData.raw (16 KB)

For comparison, I also wrote an XDMF file that describes the binary data. This works fine.
simpleData.xmf (778 Bytes)

Does this crash for other people as well? If so, I’ll create a bug report.
Or am I simply doing something wrong?

Thanks!

(Walter Alan Scott) #2

Hi Jarno,
It appears to me that you are not even getting as far as your data. Looks like you played around in the Settings file? Did you enable Auto MPI? If so, I would recommend turning it off. Generally, first thing to do if things break is go back to default. If you DIDN’T turn on MPI, then there is a different - and stranger - issue.

Alan

(Mathieu Westphal (Kitware)) #3

It is working fine here. Please reset your settings.

(Jarno van der Kolk) #4

Hi, I reset my settings by deleting ~/.config/ParaView and did the same things as before.

jarno@workjarno:~/.config$ mv ParaView/ ParaView.bak
jarno@workjarno:~/.config$ paraview 
Generic Warning: In /home/buildslave/dashboards/buildbot/paraview-pvbinsdash-linux-shared-release_superbuild/build/superbuild/paraview/src/VTK/Parallel/MPI/vtkMPICommunicator.cxx, line 71
MPI had an error
------------------------------------------------
Invalid argument, error stack:
MPI_Type_create_subarray(344): MPI_Type_create_subarray(ndims=3, array_of_sizes=0x7ffe67da0160, array_of_subsizes=0x7ffe67da0170, array_of_starts=0x7ffe67da0180, order=57, MPI_BYTE, newtype=0x7ffe67da0158) failed
MPI_Type_create_subarray(127): Argument array_of_starts has value 4 but must be within [0,0]
------------------------------------------------

application called MPI_Abort(MPI_COMM_WORLD, 269100044) - process 0
[unset]: write_line error; fd=-1 buf=:cmd=abort exitcode=269100044
:
system msg for write_line failure : Bad file descriptor

I noticed I wrote some of the Image Reader setting wrong in my post. Data extent should be from 1 to 16, not 0 to 0 of course, but it looks like you spotted that already.

Here’s my settings file, though it doesn’t contain much. ParaView5.6.0.ini (1004 Bytes)
I still double-checked the Settings screen and “Enable Auto MPI” is off.

This is on a stock install of Kubuntu 18.04 by the way.

(Mathieu Westphal (Kitware)) #5

Sorry, I mistested this.

With your setup of the reading of the .raw file, I have the following error. It is different to your error though :

ERROR: In /home/buildslave/dashboards/buildbot/paraview-pvbinsdash-linux-shared-release_superbuild/build/superbuild/paraview/src/ParaViewCore/ClientServerCore/Rendering/vtkPVImageSliceMapper.cxx, line 241
vtkPVImageSliceMapper (0xa319900): Incorrect dimensionality.
(Kyoshimi) #6

If the raw file has dimension of 16 x 16 x 16, the data extent is set as below, isn’t it?

Data Extent:
0 15
0 15
0 15

(Jarno van der Kolk) #7

Ugh, so it is… That worked. Thanks!
Been programming too much with arrays-start-at-one languages. :slight_smile:

Still somewhat strange error message I got and that it’s different from @mwestphal, but oh well.

Thanks again!