Paraview 5.8.x macos big sur freezes on any action after opening

Hi,

I have installed ParaView 5.8.0 and 5.8.1 on macos big sur. Paraview freezes on any action after opening.

I have checked related posts, but I cannot find a solution. I have tried:

  • Install and reinstall a few times
  • Restart mac
  • This seemed to be related, but I am not sure what to do with it. There is no external volume mounted

Any advice?

Thanks!

@cory.quammen

Sorry, I don’t have any advice to offer at this point.

Does your machine have the new M1 chip or Intel?

Intel chip.

Quite sure 5.8.0 was working with Catalina a month ago.
Not sure whether this helps, but this is a screenshot from the activity monitor

Yesterday I forgot to kill the process and the memory grew to 120 GB and I had to hard restart.

Just tried 5.9.0-RC4 and it works fine.

I have also tried to load a file with the --data option from the command line. The file is loaded, but as soon as I do anything else it freezes.

Thanks for trying 5.9.0-RC4.

Would you be willing to try out this binary? https://www.paraview.org/files/v5.8/ParaView-5.8.1-macOS10.15.dmg

This is a different build of 5.8.1 with a tweak to package signing required by macos.

No problem at all.

This build works fine!! Thanks a lot.

I have the same problem. Paraview 5.8 worked fine with Catalina (Intel processor). Now with Big Sur I have tried everything mentioned above but it doesn’t work. 5.8 and 5.8.1 freeze. I also tried 5.9, but all the nice features related with glyphs are simply gone in this new version.

Hmm, no glyph features should have gone away in 5.9.0. You may need to click the gear icon to show “advanced” properties. If that’s not it, please explain which features you are trying to find.

I can not use the advanced properties. It crashes any time I apply.

Hello, I have the same problem, ParaView 5.8.1 freezes for me on Big Sur, 5.9 works fine. But I need to run 5.8 at the moment because of the old Catalyst API. I tried to download the binary you provided, but the link is already broken.

Could somebody please give a link to a compiled binary 5.8 for Big Sur?

This binary https://www.paraview.org/paraview-downloads/download.php?submit=Download&version=v5.8&type=binary&os=macOS&downloadFile=ParaView-5.8.1-MPI-OSX10.12-Python2.7-64bit.dmg freezes for me as well.

One more thing to try is to remove your ParaView config files. On OS X, move ~/.config/ParaView to ~/.config/ParaViewBackup. Please let us know if this helps. If it does, Kitware may want these files to try to figure out what is going on.

1 Like

Just tried it, didn’t work. The same behaviour. I had ~/.config/ParaView and ~/.config/ Kitware, Inc., removed everything – nothing has changed.

Thank you Walter! It helped

Doesn’t always work, but it is such a simple thing, it is what I always try first.

I am facing same problem. But I could not access above download link.
https://www.paraview.org/files/v5.8/ParaView-5.8.1-macOS10.15.dmg