Paraview App not supported on Big Sur Version 11.6 (*not* M1 chip)

I’m running MacOs Big Sur Version 11.6 w/ Processor: 2.4 GHz 8-Core Intel Core i9

When I try to install Paraview (from either the .dmg or .pkg), it warns “There may be a problem with this disk image. Are you sure you want to open it?”
I go ahead and click open because I’ve downloaded this file from the ParaView website directly.
After clicking agree to the terms and conditions, it allows me to drag ParaView into the Applications Folder. But the ParaView icon has a white Prohibition sign through it, even after I drag it into the Apps folder. Now, when I try to click on ParaView to open it, I get

You can’t open the application 
because this application
 is not supported on this Mac.

Does anyone know how I can get ParaView running?

Which file name did you download? *-x86_64.pkg or *-x86_64.dmg?

I tried both.
The ParaView 5.9.1 (which is the previous release to the most recent) and worked perfectly. But 5.10.0 doesn’t seem to.

You for sure downloaded the *x86_64.pkg/.dmg files and not the *arm64.dmg or *arm64.pkg files? The arm64 downloads are new for 5.10, and they happen to be listed at the top of the downloads page. For an Intel chip, you must use the *x86_64.pkg/.dmg files.