ParaView crashing on windows 11 while opening large file

Hello,

I am opening this topic because I am trying to load a large file (278MB) into paraview 5.9.1 on windows 11 and it keeps crashing.
I’ve read some similar issues here and so I checked the event viewer and the following event appears:

**-** **EventData**

**AppName** paraview.exe

**AppVersion** 0.0.0.0

**AppTimeStamp** 60a2bd00

**ModuleName** vtkFiltersGeometry-pv5.9.dll

**ModuleVersion** 0.0.0.0

**ModuleTimeStamp** 60a2b5fe

**ExceptionCode** c0000005

**FaultingOffset** 000000000000c2ee

**ProcessId** 0x3328

**ProcessCreationTime** 0x1d913d7de2b0069

**AppPath** C:\Program Files\ParaView 5.9.1-Windows-Python3.8-msvc2017-64bit\bin\paraview.exe

**ModulePath** C:\Program Files\ParaView 5.9.1-Windows-Python3.8-msvc2017-64bit\bin\vtkFiltersGeometry-pv5.9.dll

**IntegratorReportId** df143688-3877-40a1-b3dd-c70cc801befa

**PackageFullName**

**PackageRelativeAppId**

I have also tried opening a smaller file (41,1 MB), but it crashes again. Significantly smaller files can be opened without issues.

I have already reset the app to default settings, tried to update my graphic drivers and checked the task manager in case it’s a memory problem, but nothing changed.
This is the information of the About dialog in the paraview app, in case it helps :

Client Information:
Version: 5.9.1
VTK Version: 
Qt Version: 5.15.1
vtkIdType size: 64bits
Embedded Python: On
Python Library Path: C:\Program Files\ParaView 5.9.1-Windows-Python3.8-msvc2017-64bit\bin\lib
Python Library Version: 3.8.6 (tags/v3.8.6:db45529, Sep 23 2020, 15:52:53) [MSC v.1927 64 bit (AMD64)]
Python Numpy Support: On
Python Numpy Path: C:\Program Files\ParaView 5.9.1-Windows-Python3.8-msvc2017-64bit\bin\Lib\site-packages\numpy
Python Numpy Version: 1.19.2
Python Matplotlib Support: On
Python Matplotlib Path: C:\Program Files\ParaView 5.9.1-Windows-Python3.8-msvc2017-64bit\bin\Lib\site-packages\matplotlib
Python Matplotlib Version: 3.2.1
Python Testing: Off
MPI Enabled: Off
Disable Registry: Off
Test Directory: 
Data Directory: 
OpenGL Vendor: Intel
OpenGL Version: 3.2.0 - Build 31.0.101.1999
OpenGL Renderer: Intel(R) UHD Graphics

Connection Information:
Remote Connection: No

Any help would be greatly appreciated. Thanks in advance.

Hi @chichi72

278Mb is not big at all and there should be no issue.

Please share a dataset that lead to a crash.

Best,

Hello again,

It seems like the files cannot be uploaded because of an error, so I have zipped them and you can find them here : vtk files
It is possible that they are badly formatted (especially the vectors). Let me know in case that’s the problem so I can have a better look at the format.

Thanks!

(The two files are two separate datasets. I’m sending both since I have mentioned them before. )

Confirmed

Hello,

Turns out it was my mistake, because the vtk file was badly formatted.
(for what it’s worth, I was appointing the wrong number of points to a specific cell type)

I thought I should let you know since it’s solved now.

Thanks for the help anyways!

A segffault is still an issue to fix though