Paraview GUI not connecting

Hi All,

Ill try to give as many details as possible. I’m currently working on a JupyterHub running a pretty standard version of Ubuntu 22.04. We are using TigerVNC to connect to an XFCE4 desktop environment. I have tried using the superbuild, downloading through apt, conda, etc, but the least problems so far has been directly from the Paraview website. It seems to not be able to recognize the xcb library, or might be confusing QT between conda and system. Below, I’ve attached a screenshot with my exact error, which has been discussed here, but was never answered. Happy to provide more information if necessary. It would be really great to have this working on my system!

Are you able to run the binary release of ParaView at least ?

This is the Paraview 5.11.2 binary release that I ran/screenshotted above. This may be more of a QT question than Paraview, but I thought to ask here first.

Looks like ParaView is trying to use libs from anaconda. This should not happen, make sure your environnement is clean.

I see. Any recommendations as to where I should start/flags I can add to direct ParaView to non conda libs?

Look at the following env var: LD_LIBRARY_PATH, LD_PRELOAD

I have tried a couple of different flags and installing packages through apt instead of conda in this image. I’m attaching the full output/stderr. If I need to install xcb through apt, would this package be the correct one to install? I appreciate the help thus far, but still have a bit of confusion towards finding a solution.
output.txt (5.2 KB)

If you are using ParaView from conda, I’m afraid I cant help you.

Please use our binary release instead:

Apologies, let me clarify. I am using the binary release, 5.11. The dependencies are the only things I’ve been installing through apt/conda. It seems like there is a compatibility problem somewhere, but I’m not familiar enough with the requirements, which is why I attached the full debug output.

which dependencies ?

ParaView has no dependencies that should be installed through conda.

Because I am using a Jupyterhub instance, the desktop portion is vnc/websockify to allow me to utilize a desktop environment. I believe that adds some confusion to the system defaults and causes the error i’ve shown in screenshots/debug reports. I can try to provide more specific details, but my first post was mostly the extent of my knowledge.

I’d strongly recommend trying to reproduce the issue on a clean system first.