ParaView Illegal instruction (core dumped)

I have to connect to a HPC center running pvserver, in which the ParaView install is version 5.6.1. When I make the remote connection from my office PC, the connection complains about version mismatch

ERROR: In /tmp/ParaView/5.6.1/intel-2018.5.274-mpi/ParaView-v5.6.1/VTK/Parallel/Core/vtkSocketCommunicator.cxx, line 502
vtkSocketCommunicator (0x1ad0a80): Client/server version hash mismatch.

ERROR: In /tmp/ParaView/5.6.1/intel-2018.5.274-mpi/ParaView-v5.6.1/ParaViewCore/ClientServerCore/Core/vtkTCPNetworkAccessManager.cxx, line 333
vtkTCPNetworkAccessManager (0xe81c60): 
Connection failed during handshake. vtkSocketCommunicator::GetVersion()
 returns different values on the two connecting processes
 (Current value: 100).

I’m running Ubuntu 18LTS, where I originally tried to use the package build (version 5.4.1). This resulted in the error above. I did some research and it seems the solution is to get the exact same version. I went over to ParaView download and grabbed the binary version 5.6.1. When I try to run the executable, I get the following error

Illegal instruction (core dumped)

That is all that is spit out and I have no clue what I can do to fix it. I tried to download binary version 5.7.0-RC1 and 5.7.0-RC4 where both executables seems to work fine, but again I can not connect to the server because of version mismatch.

Assuming I can not touch the server, how do I fix the “Illegal instruction” error to get the version 5.6.1 binary working?

You indeed need to use the exact same version.

Regarding your issue with 5.6.1 :
Which CPU do you have ?

A solution may be to build ParaView yourself.

GWAVE, you are likely running into an issue described here:

The fix is in ParaView 5.7.0. Unless you can build the ParaView 5.6.1 client yourself without the AVX instruction set support, your only option is to try ParaView 5.6.0 with the 5.6.1 server (might work) or wait until the server is updated to 5.7.0 and use the ParaView 5.7.0 client.

@mwestphal and @cory.quammen Thanks for your support. I ended up building version 5.6.1 on my own (without “super build”), which proved to be a bit of a challenge, but it did work connecting to the remote server.