Paraview installation error in Linux subsystem windows 10

(Sreekar Reddy) #1

Hi
I’m a newbie at Ubuntu and terminal programming. I’ve installed Ubuntu as a subsystem in windows 10 for OpenFOAM. I’ve been able to install OpenFOAM successfully but paraview is not installing in any way.
I tried rheologic remix pack for OpenFOAM 4.x and copied all the bashrc commands in the .bashrc. It should contain paraview as well but it didn’t show up.
Tried installing deb pack for Ubuntu18.04, it ran correctly but I don’t know how to access it.
And I tried opening the paraview from the third-party folder unpacked from rheologic. There is a paraview file but couldn’t find a way to open it.

Everytime I try to run the application, it shows up with this error.
/home/sree/OpenFOAM/ThirdParty-4.x/platforms/linux64Gcc48/ParaView-4.1.0/lib/paraview-4.1/paraview: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory

Is there anything I should have done. Please help me

(Mathieu Westphal (Kitware)) #2

ParaView is not tested and probably not compatible with WSL.

Why not installing the Windows version of ParaView ?

(Simon) #3

One possible reason is that there are files that Paraview will open on linux but not on Windows: https://gitlab.kitware.com/paraview/paraview/issues/18661. That’s why I’m trying to run it in WSL.

Fortunately Ubuntu’s repos have a paraview package, which works nicely in WSL (so long as one has an X-server installed). Unfortunately, it’s version 5.4.1, and the types of files that I want to view were’t well supported back then.

So I tried downloading the linux tarball for 5.6.0 from https://www.paraview.org/download/. Once untarred there was a bin/paraview executable, so I tried that… and got exactly the same error as the original poster.

That error is fixed simply by installing the missing dependency:
“sudo apt install libglu1-mesa”.

Now Paraview will start, but it gets as far as “Your OpenGL drivers don’t support required features for basic rendering. Application cannot continue. Please exit and use an older version”.

…which is pretty unhelpful. It produces this in the terminal:
“ERROR: In /home/buildslave/dashboards/buildbot/paraview-pvbinsdash-linux-shared-release_superbuild/build/superbuild/paraview/src/VTK/Rendering/OpenGL2/vtkOpenGLRenderWindow.cxx, line 749
vtkXOpenGLRenderWindow (0x5076470): Unable to find a valid OpenGL 3.2 or later implementation.”

So. It looks like older versions of Paraview worked just fine in WSL, but 5.6 doesn’t. :frowning:

(Lutz Hofmann) #4

In my experience, the OpenGL error has to do with the X server that runs on Windows.
I’ve had some success using VcXsrv, with hardware acceleration disabled, and LIBGL_ALWAYS_INDIRECT=0 as well as QT_X11_NO_MITSHM=1 set in WSL.

(Mathieu Westphal (Kitware)) #5

Indeed, it looks like the provided OpenGL implementation by wsl does not support newer features that are needed in ParaView.

I would still like to know the motivation for running in the WSL instead of the window-native version ?

(Simon) #6

I would still like to know the motivation for running in the WSL instead of the window-native version ?

I can’t speak for the OP, but in my case it was because of this issue:
https://gitlab.kitware.com/paraview/paraview/issues/18661

Which happily seems to be fixed in yesterday’s nightly :smiley: