Paraview not launching after download

Hello, I have downloaded paraview (tried the5.5.1 exe file and the msi file and the zip file) for windows 10. Every time I run the installer, the install finishes but paraview doesnt open, nor can i find any .exe file that I can run. I have an intel cpu and nvidia gpu.
Is there any solution for this issue?

Edit: I found the executable file, but when i run the file I get the following error:
The code execution cannot be proceeded because msmpi.dll was not found.

Any help would be immensely appreciated.

Welcome to the ParaView community Vassilis!

Although @mwestphal will probably reply with better information than I will, a few things to try. Go to the website, and try installing the non MPI 5.12.0-RC2 version. 5.5.1 is as old as I am (and that isn’t good…) Next, try downloading the non MPI .zip version rather than the installer. Try running the .zip version. Does that work?

I’d suggest to use the last non-mpi release version using the installer: