ParaView not starting on Windows Server 2019 Azure VM (Data Science VM image from MS)

I have installed the latest version ParaView 5.10.1 on the Azure VM below however when I run it the ParaView desktop appears briefly before disappearing.
Standard NC4as T4 v3 (4 vcpus, 28 GiB memory)
Data Science Virtual Machine - Windows 2019 (
I have tried a few older versions and on another Windows Server 2019 Azure VM with the same result.
I generated the trace log, the last 3 lines are below:
2.897s) [paraview ]vtkWin32OpenGLRenderWin:680 ERR| vtkWin32OpenGLRenderWindow (0000026DF3177B00): failed to get wglChoosePixelFormatARB
( 2.910s) [paraview ]vtkWin32OpenGLRenderWin:758 ERR| vtkWin32OpenGLRenderWindow (0000026DF3177B00): failed to get valid pixel format.
( 2.911s) [paraview ]vtkOpenGLRenderWindow.c:493 ERR| vtkWin32OpenGLRenderWindow (0000026DF3177B00): GLEW could not be initialized: Missing GL version

Any suggestions? Is Windows Server 2019 not supported?

This is now working, the resolution/fix was very simple, here it is in case anyone interested:
I deployed a new Azure VM using the “NVIDIA RTX Virtual Workstation - WinServer 2019” marketplace image and the Standard NC4as T4 v3 azure vm type. I then installed Paraview 5.10.1 and that worked, proving it was a GPU or NVIDIA issue.
So I returned to my original Azure VM (windows server 2019, also Standard NC4as T4 v3), manually installed the GRID 13.1 (472.39) NVIDIA drivers, rebooted, uninstalled & reinstalled Paraview 5.10.1 and that worked. Hope that helps!

1 Like