Paraview not stitching data from different processes

Hello everyone,

I’m trying to view my simulation output in v10. It’s transport of a scalar in a velocity field. I ran the simulation in parallel using 8 processes. When I converted CellDatatoPointData and plotted a contour, I saw that data from different processes are not ‘stitched’ at processor boundaries. Please see the gaps in the scalar surface attached. Could someone please help and tell me how to stitch them properly?

Many thanks,

Please share your data.

Hello Mathieu,

Please see this link: Dropbox - ScalarTransport.tar.gz - Simplify your life


You need ghost cells in order for ths stitching to happens correctly and ther are missing from your data.

The usual fix is to use GhostCellGenerator however this filter seems to be non-compatible with Overlapping AMR for some reasons. Please open an issue:

Thanks Mathieu. But, I don’t think the ghost cell data are absent. Because it looks proper when I tried to visualise in VisIt.


There is a ghost array but it seems to be all zeros when being read in ParaView at least: