Paraview script for image_capturing and file_saving but I can't run it on my University Server, even though all Libraries are correctly installed

so me and my advisor wanted to ta save some scenes from MANY data. Basically I made a trace and it does the job for the data on my PC.

After running it through ssh with No-X I got this error:

<paraview.servermanager.XMLUnstructuredGridReader object at 0x2b3bc799c2e0>
libGL error: unable to load driver:
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  66
  Current serial number in output stream:  67

then I added -X, and even though I was able to do some other processes (cut data so its size is small), when it came to image output, I got this error:

(  71.382s) [main thread     ]vtkXOpenGLRenderWindow.:451    ERR| vtkXOpenGLRenderWindow (0x564e23768ae0): bad X server connection. DISPLAY=:0. Aborting.

I’m pretty sure I should be able to run the Python Script without using ssh-X.

Has any of you any idea what to do next?

Should I install the headless paraview like I read in some similar probelm?

Can you try running using

parameter to pvpython (or pvbatch)


I tried it. Didn’t work (Actually these errors also included a try with force-offscreen-rendering.

I downloaded the headless version of Paraview, and decided to run it. I got some "use ‘Line’ instead of ‘high resolution line’ " and now I send the script again to run and hopefull the Osmesa Version will be enough. :frowning:

Αctually it worked! Downloaded the Osmesa version, changed some thingies ( Point Source to Cloud , HD Line to Line as pointed out in documentation) and everything is smooth!