Paraview shuts down while running a OpenFoam tutorial case with error: "non-digit character" in powk file

Hi there,

I have a problem while running paraview, the error came as:

ERROR: In /home/yuling/OpenFOAM/ThirdParty-v2006/ParaView-v5.6.3/VTK/IO/Geometry/vtkOpenFOAMReader.cxx, line 7495
vtkOpenFOAMReaderPrivate (0x55b41917a000): Error reading line 18 of /home/yuling/OpenFOAM/yuling-v2006/run/tutorials/incompressible/pisoFoam/RAS/cavity/2.5/powk: Expected a number, found a non-digit character .

Segmentation fault (core dumped)

I’m following OpenFoam’s tutorial to solve the lid-driven cavity case with k-\epsilon model, paraview showed normally the results at time =0.25s, 0.375s, 0.625s… but it shut down when I chose time=0.5s, 1s, 1.5s etc then the error above appeared.

Please find the powk file at t=2.5s and the log file after pisoFoam here:
powk (5.0 KB)
log (2.8 MB)

Otherwise, I’d like to update paraview5.6.3 to 5.8.0, but version 5.6.3 came with ThirdParty-v2006 by default. Could anyone tell me how to change the paraview path to 5.8.0 once I install the new version, so that when I run paraFoam in the terminal, 5.8.0 will be open ?

Thank you for your future help.
Best regards!

Please try with our last binary release from here :

Hi there,

I have the same issue than you, using openFOAM v2012. Have you found any solution ? it doesn’t seem that the error is coming from ParaView. If you look at the powk file (which is created only starting from the time 0.5, explaining why we paraview is functioning well before this time) at line 18, you can see that there are no integers (which seems odd to me because we are speaking about dimensions). If you replace the numbers by integers, there is no more issues.

I have found out this yesterday, and I cannot explain yet what is powk (CFD is a far away memory) and why its dimension is 0.5 rather than integer.

Chaging to Paraview 5.9 does not correct the problem. If you have found something else, please let me know, as I will if I find something,

Best regards,


Hi Dregy,

Thanks for your respond!
I didn’t find the solution until you send me this message, I agree with you that this error is not due to Paraview but powk file.
If we look up the FOpow file attached, at line 19 the scale is set as 0.5, I assume that we could modify this to resolve our problem.
For information, I no longer use the pow function object so I didn’t test. But I’ll be pleased to know if this works. :slight_smile:
tutorials_incompressible_pisoFoam_RAS_cavity_system_FOpow (1.2 KB)

scale           0.5;

PS: For people looking for how to switch 2 versions as my last question in August, we need to check alias &/ bashrc environment.

Best regards,

Hi Yuling,

Thank you for your respond ! If you do not use pow anymore, what do you use instead and how did you manage to do the tutorial ?

I’ve tried 2 things:

  • Changing the scales does not affect the result (as it does not change the dimension of powk) but changing n from 0.25 to 0.5 changes the dimension of powk from [0 0.5 -0.5 0 0 0 0] to [0 1 -1 0 0 0 0](but as I said, I do not know its dimension as I haven’t done k epsilon modeling for a long while) and there is no more errors. But I do not know yet the impact of this change on the overall simulation

  • I have changed ‘checkDimensionalEntry’ from false to true. Lauching pisoFoam gives now an error:
    “FOAM FATAL ERROR: different dimension for ‘(a+b)’ dimensions [0 0.5 -0.5 0 0 0 0] != [0 0 0 0 0 0 0]”
    After checking on several forums, it seems that now pisoFoam verifies the dimension of powk and only continues if it is correct. I then assume that powk should be a dimensionless number, so the FOpow should be modified in this way.

I’ll keep you informed if I manage to find more,

Best regards,



It’s true that we couldn’t ensure the impact to the overall simulation by changing the FOpow file.
I’m sorry to tell you that I skipped this error part of tutorial.
As I didn’t see pow function in other tutorials and I work more on simpleFoam (whose time directories are integers, is it a factor here? ) where I don’t encounter such problem, I left it behind.

Anyways, I hope you find a solution.
Best regards,


I’ve made some tests, even if you don’t allow FOpow to execute (via controlDir, shutting down the include), the case can be launched, and there is no other occurence of powk elsewhere. Anyway, the case seems broken as nothing really happen.
So it was a good choice to skip this tutorial, I’ll do the same !

Thank you for your help,

Best regards,


1 Like

Problem fixed as part of merge-request 7602