ParaView state file problem: state file does not show a slice from a dataset

Hello eveyrone,
I’ve made a pvsm state and when I load the state, this slice I’ve made is not shown in the View. When I have a dataset without modifications or filters applied everything works fine, but as soon as I do Slice or Clip this issue arises. There is a message as well in the output message box. Can someone suggest where to look for a problem?

please share data and steps to repro

@mwestphal Can I send you data via email?

And the steps:

  1. Firstly load vtu.series file and use XML poly data reader
  2. Load 3d velocity netcdf file using NETCDF reader, uncheck spherical coordinates, check fill value with none and switch output type from automatic to image
  3. Calculate velocity vector by using Calculator filter (uiHat+vjHat+w*kHat)
  4. Make a slice of the velocity vector data
  5. Programmable filter:
    the code :
    from datetime import datetime, timedelta
    t = inputs[0].GetInformation().Get(vtk.vtkDataObject.DATA_TIME_STEP())
    time_origin = datetime.strptime(“2019-07-25 00:00:00”, “%Y-%m-%d %H:%M:%S”)
    humantime = time_origin + timedelta(seconds=t)

to = self.GetTableOutput()
arr = vtk.vtkStringArray()
arr.InsertNextValue("{}".format(humantime.strftime("%Y-%m-%d %H:%M:%S")))

Switch the output dataset type to vtkTable
6. Annotate Attribute Data apply this and switch to humantime in Select Input Array
and apply and save this as a pvsm file.
and when I try to load again I don’t see the slice at all

Here is the state file for this data
test.pvsm (620.0 KB)

I requested access already.

OK, I hope I’ve enabled it just now.

Not enterely sure but it looks like data (u, theta) is missing on some of the timesteps, this may causes this issue.

OK, I will check that, thank you.

I have one more question if you can tell me your opinion please, is it possible that this programmable filter code I use is messing something up? This part with switching to vtk table maybe?

Your programmable filter is not using the data mentionned in the error, so I do not see how this is related. You can just remove it and see if the error is stil present.

Oh, OK I see. Thank you.

The error is present even without the programmable filter.
The error only happens when I open these 2 datasets at the same time. I tried just doing the slice to the 3d set with programmable filter included and everything works perfectly. As soon as I open this vtk as well, then the slice is not existing (with or without the programmable filter).

could you provide simples steps to repro ?

so steps with error:

  1. open evropska_surfs_var_theta_surface.vtu.series with XML polydata reader.
    2 open , netcdf reader, uncheck spehrical coordinates, check replace fill value with none, and switch output type to image
  2. choose theta for example
  3. Make a slice to that dataset
  4. save state and reload the state and this is what I got

The same thing happens when I calculate velocity vector and apply the Slice to that data set etc.

Btw, we checked the data and in 3d output all varaibles are in all time steps, the only different thing is that surface data are from 600 to 6001. But the 3d ouput are from 0 to 5401. This is only difference.

Looks like I missed one glaring problem. Your .vtu files contains polydata and should all be renammed as .vtp files.

Hi, I tested it with vtp and it works perfectly like this.

But when I add this programmable filter that I have I get the same error and same behavior as before. I will see what can be done about it. Thank you for the help.