Paraview stops responding when loading large csv file

I am trying to load a large 16GB .csv in Paraview (version 5.10.1). When I click “apply”, Paraview immediately stops responding and I have to restart the program. When I try to just load the first few lines of my file it works fine, but when I try the whole file, it stops working. I have read similar support pages and tried to reset to the default settings and that did not work. I am wondering if I should try downloading an older version of Paraview? I have attached a photo of what my file looks like. I am aware of the extra commas at the beginning and end so I clicked the “merge consecutive deliminters” option before hitting “apply”. Any help would be greatly appreciated.


On Windows? Try Mac or Linux.

Yes on windows.

It may be that you’re running into this issue. Error reading large VTK files in the Windows version

Because of the way streams are loaded, Windows can only traverse up to 2Gb of data.

I just tried it on Mac and got the same issue as on windows.

I suggest you cut the file size down to 2Gb and try again.

I will try that now. Isn’t paraview supposed to work with large files though?

It works when I make the file smaller. Is there a way to load a bunch of smaller files and merge them together in Paraview? Although this is not ideal since the file is very large…

Are you building Paraview locally or just downloading the binary? If you’re building it you can increase the file size limit to 4Gb on Windows using the code change outlined here Error reading large VTK files in the Windows version - #22 by todoooo

Edit: Sorry that will only work for the XML reader.

You should be able to combine the tabular data inside Paraview.

1 Like