ParaView Superbuild Failing on Windows

I am trying to build the ParaView Superbuild on Windows 10 and am running into an error with CMake GUI:

CMake Error at superbuild/cmake/SuperbuildUtils.cmake:45 (message):
  CMAKE_BUILD_TYPE must be one of: Release, RelWithDebInfo (found Debug).
Call Stack (most recent call first):
  superbuild/CMakeLists.txt:29 (include)

Below is my setup:


OS: Windows 10 Enterprise, x64-bit, Build 1909
CPU: 2x Intel(R) Xeon(R) Gold 6248R
Disk: 2TB NVMe M.2 SSD
RAM: 192 GB DDR4
Compute GPUs: 2x NVIDIA Quadro RTX8000 in TCC mode with NVLink
Display GPU: 1x NVIDIA Quadro RTX4000


ParaView: Master branch cloned from repo into subfolder src with

> cd C:\Paraview
> git clone --recursive src

in an x64 Native Tools Command Prompt for VS 2019 in Administrator mode.

Visual Studio: [Visual Studio 16 2019 Community][1]
Windows SDK: [10.0.19041.0][2], targeting 10.0.18363
Python: [3.8.10 x64-bit][3]
CMake: [3.21.1][4] (I use CMake-GUI)
vcpkg: [2021-08-12][5]

If anyone can provide me help to figure out why this error is occurring, I would greatly appreciate it. I’ve reviewed a couple of similar posts and the most relevant appears to be this:

[Windows] Release configuration fails when running ninja install

Thank you!

Yes, this is an intentional limitation; you must set CMAKE_BUILD_TYPE on Windows. Why it defaults to Debug is some legacy CMake behavior, but we can’t tell what was default versus explicitly requested, so all we can do is error and punt (since guessing what might be wanted is difficult).

I would recommend using Release and then setting RelWithDebInfo for the various CMAKE_BUILD_TYPE_<project> variables that are offered for the projects you do care about (FWIW, not many offer it). This is all covered in the README (though admittedly, probably not in the most approachable way). Improvements that can be made there or in the error message would be appreciated.