Paraview texture buffer size (or driver) issue

Hello,

I installed paraview using “sudo apt install paraview” command on ubuntu 20.04 which is installed on windows 11 pro wsl. It was working well for several weeks and since today when I try to load an openfoam case, paraview gives me the following error: “Attempt to use a texture buffer exceeding your hardware’s limits. This can happen when trying to color by cell data with a large dataset. Hardware limit is 65536 values while 161058 was requested.”

I assumed it is a driver issue and I must say that I’m fairly new to ubuntu and paraview. I checked my drivers without knowing exactly what I’m doing. I ran the command:
glxinfo|egrep “OpenGL version|OpenGL vendor|OpenGL renderer”

The output is:

OpenGL vendor string: Microsoft Corporation
OpenGL renderer string: D3D12 (NVIDIA GeForce RTX 3050 Ti Laptop GPU)
OpenGL version string: 3.3 (Compatibility Profile) Mesa 22.0.3 - kisak-mesa PPA

inxi -F commands gives the following output about graphics:

Graphics:
Device-1: Microsoft driver: dxgkrnl v: N/A
Device-2: Microsoft driver: dxgkrnl v: N/A
Display: wayland server: Microsoft Corporation X.org driver:
gpu: dxgkrnl,dxgkrnl resolution: 1920x1080~60Hz
OpenGL: renderer: D3D12 (NVIDIA GeForce RTX 3050 Ti Laptop GPU)
v: 3.3 Mesa 22.0.3 - kisak-mesa PPA

Also following command gives no output:

sudo ubuntu-drivers devices

I also tried update, upgrade and even upgrading to ubuntu 22.04. Problem still stands. I know it is not “unsupported graphics card” issu since it was working fine until now.

I kindly request some urgent help to solve this issue.