ParaView version


I installed ParaView on Amazon EC2 using “sudo apt install paraview”.
How do I find the ParaView version?
I tried : “paraview --version” and “paraview --V” but I got the message:
“paraview: cannot connect to X server”

paraview is an X application and requires a Xorg server to be able to run.

Do you mean to use pvserver or pvbatch ? They do not require Xorg.

./bin/pvserver --version

1 Like

Thank you Mathieu.

Regarding this issue, I installed ParaView on an Amazon EC2 instance, using “sudo apt install paraview”.
The version is apparently 5.4.1. I started “pvserver” there. The messages show that it’s running.

I downloaded the ParaView desktop app version 5.4.1 to my computer (I was using 5.6)
I tried to connect as a client using the 5.4.1 version, but this was not successful.

On my EC2 instance, port 11111 is open to receive communication.

What am I missing? Do I need to use special configurations? Am I only able to use the ParaView web (Visualizer) as a client when I am connecting to an EC2 instance?

are you able to ping your instance or do you use multiple ssh connection ?

I only use one ssh connection.

is the port 11111 open ?

It supposed to be open, I added it on the security group.

when you run pvserver and tries to connect to it with your ParaView, is anything shown in the pvserver output ?

No. No message. On the ParaView desktop app the message is “something is wrong with the socket”…

ParaView can’t communicate with pvserver at all. You will have to check your network.

1 Like

Ok, thank you. I will do that. Just to be clear, this procedure is ok, right? It supposed to work?

Yes it is.

Thank you very much. I will check my network.

Ok. So I checked my network and it’s ok.

Apparently you need to connect with another ssh connection to the EC2 instance (besides the one that you are already using to control your instance).

You need to create a port forwarding using plink in windows (run it from inside the PuTTY folder). It’s something similar in Mac (not plink).

the link is the following format:
plink -i “your_amazon_key” your_amazon_username@your_amazon_host -L 11111:localhost:11111

After connecting with another connection, you can start your ParaView desktop app and connect to the server using regular localhost server configuration (not remote host).

However, after doing so I got the following error message on the pvserver side:

ERROR: In /build/paraview-lH8wFv/paraview-5.4.1+dfsg3/ParaViewCore/ClientServerCore/Core/vtkTCPNetworkAccessManager.cxx, line 413
vtkTCPNetworkAccessManager (0x55ef54b202f0):

Connection failed during handshake. This can happen for the following reasons:

  1. Connection dropped during the handshake.
  2. vtkSocketCommunicator::GetVersion() returns different values on the
    two connecting processes (Current value: 100).
  3. ParaView handshake strings are different on the two connecting
    processes (Current value: paraview.5.4.renderingbackend.opengl).

What seems to be the error?

Thank you for your time,

You can do it like that but it is not needed if your port is open.

The connection is not working probably because they are not using the same backend.
copy the paraview you downloaded locally to your server and run this pvserver instead.

But who are they? Amazon? But I used “sudo apt install paraview”

“they” are the people packaging paraview for your linux distribution on your server, probably Ubuntu.

So download and extract our release of ParaView in your server instead of using the one provided by ubuntu.

1 Like

I downloaded version 5.4.1 and it’s working.