Paraview VR simulation returning nothing but black.


I am currently working on a project that displays California’s terrain. My issue is when I click “Send to OpenVR”, using my oculus Quest2, I can see in the headset that paraview is loading but there is nothing but black in the headset aside from the controllers. When I click on “Show VR View” the terrain appears on my monitor.

I am using version 5.10.1 and have downgraded to 5.9.1 to test that out but no success.

Any questions or possible solutions would be much appreciated.

Thank you.

@Tiffany_Chhim @martink @Scott_Wittenburg

Hello @diaz1,

Does it work for other datasets?
For instance, does the same thing happen if you try to visualize a simple sphere in VR?

@Tiffany_Chhim Yes I’ve tried simpler data sets and I still get the same results. I have not tried a sphere but it was similar in terms of simplicity.

I am having a very similar problem to @diaz1’s. I am using the same PV version but a Vive Pro 2 headset. I’ve tried to visualize very simple objects (e.g. a cone or box created within PV) but they don’t show up in VR, only in the “Show VR View” window.
Has anyone been able to come up with a solution for this?

Thank you!

Please share the content of the “Help → About” dialog

From “help” → “about” I get:

Client Information:
Version: 5.10.1
VTK Version: 9.0.20210922
Qt Version: 5.15.2
vtkIdType size: 64bits
Embedded Python: On
Python Library Path: C:\Program Files\ParaView 5.10.1-Windows-Python3.9-msvc2017-AMD64\bin\lib
Python Library Version: 3.9.5 (tags/v3.9.5:0a7dcbd, May 3 2021, 17:27:52) [MSC v.1928 64 bit (AMD64)]
Python Numpy Support: On
Python Numpy Path: C:\Program Files\ParaView 5.10.1-Windows-Python3.9-msvc2017-AMD64\bin\Lib\site-packages\numpy
Python Numpy Version: 1.21.1
Python Matplotlib Support: On
Python Matplotlib Path: C:\Program Files\ParaView 5.10.1-Windows-Python3.9-msvc2017-AMD64\bin\Lib\site-packages\matplotlib
Python Matplotlib Version: 3.2.1
Python Testing: Off
MPI Enabled: Off
ParaView Build ID: superbuild 6dd132601dbb2a9ebdc0d31825989f5b92595b76 (!969)
Disable Registry: Off
Test Directory:
Data Directory:
SMP Backend: TBB
SMP Max Number of Threads: 20
OpenGL Vendor: Intel
OpenGL Version: 3.2.0 - Build
OpenGL Renderer: Intel(R) Iris(R) Xe Graphics

Connection Information:
Remote Connection: No

OpenGL Vendor: Intel
OpenGL Version: 3.2.0 - Build
OpenGL Renderer: Intel(R) Iris(R) Xe Graphics

This is a CPU chipset, you should use your actual GPU.

Okay, thank you! I’m very new to working with PV though, how do I change this?

This is not related to ParaView. You should make sure you GPU driver is correctly installed.

Here is some background info on setting ParaView up to use your GPU whether it is NVIDIA or AMD: This presumes you have a so-called “discrete” GPU installed on your system, which we are assuming exists (but that may be wrong).

1 Like