Pareview reads my single file fine but not as group!

Paraview reads single file without asking any specific reader and it works perfectly fine. However, when I want to read the files as group, it asks reader to choose and I have no idea what to choose?! I check most of them and they do not work for me. Anybody know any solution?
My files in the link below:
https://drive.google.com/drive/folders/1UZofth-d3CKRGJtkUkgezoLxhbc1Is0s?usp=share_link


Hi @Cavid_Azimi

The Step_…vtk is a .pvsm file, rename it to pvsm.
A fileseries is not a literal file but a concept.

Then just open the virtual Step_…vtk

hth,

1 Like

To be clear, @mwestphal means to rename Step_..vtk to Step.pvsm or something else with a .pvsm extension.

pvsm files need to be loaded by using FileLoad State instead of Open. I do note that this pvsm file must have been created with a different set of vtk files. I tried loading it, and the filenames were different than the ones you provided.

If you don’t care about loading the pvsm file (né Step_..vtk), you can just delete it. The real problem is that ParaView is grouping the pvsm file with the vtk files, and that breaks the reader.

2 Likes

Thanks @mwestphal and @Kenneth_Moreland for responces.
After renaming the file to Step_…pvsm, I can open it and it works fine. But, when I tried using FileLoad State, it popped-up “Load State Options” window and after leaving the default option crashes!
Is there any advantage using the FileLoad State instead of Opening?


Thanks,
Javid

To be clear FileLoad State is for loading the pvsm file exclusively. It does not load a group of files and will behave unexpectedly if you try to load anything other than a pvsm file. My guess is that you tried to load something that was not the pvsm file. Or possibly it was written with files that you no longer have.