plot over line bug in 5.10rc1

Hi! I’ve noticed a different behavior of Plot Over Line filter in 5.9 and 5.10rc1 when plotting data near the boundary with different resolutions. Hope two figures below show the point. The original data is 2D array (vtr, data is attached to the nodes) and plots show the distribution near the bottom boundary (the boundary is x=0 and lines are x=1e-6). Array is 201x51 nodes (201 nodes along the bottom boundary). In the new version, 5.10rc1, for resolution 1000 a lot of 0 data points on the line are generated, for 200 all generated points are 0 except the one in the beginning and for 201 the curve looks as expected. In the stable version, 5.9.1, all three resolutions give almost the same results.

Env: debian testing amd64 with KDE.

dump_full.i00210.probe0.vtr (448.0 KB)

test510rc1.pvsm (711.7 KB)

test591.pvsm (583.2 KB)

Hi Gena,
I tried your excellent examples, and replicate what you show. 5.9.1 and 5.10.0-RC1 are in deed different. I then tried recreating the images from scratch (wondering if the issue was in the state file), and 5.9.1 and 5.10.0-RC1 look identical, and very similar to your test591. Could you try making these plots from scratch, and if you still see issues, give us detailed directions how to replicate the issue without a state file?
Thanks, Alan

Hi, Alan,

Yep, I still see the issue. Steps to reproduce (paraview 5.10-rc1):

  1. open the vtr file
  2. choose Plot Over Line filter and select Z Axis on its Properties pane, leave the rest options default
  3. hit apply, LineCharView appears and see the issue

PlotOverLine was reworked, @timothee.chabat may know more.

After some digging it is because tolerance is not handled correctly in the new implementation of this filter. I can reproduce the error using the Legacy Resample With DataSet (which is the filter used by plot over line under the hood), a line source and a custom tolerance level. I will open an issue on gitlab and try to fix this when I have time.

@utkarsh.ayachit @cory.quammen Issue for 5.10?

@timothee.chabat I have a fix.

@wascott I’m backporting to 5.10

Edit: Here’s the MR

And the bug report is here: Thanks Yohann.

Cool thanks !