Probing in 2D flow field

Hi,

I am new to Paraview. I am using version 5.8.0. Now I have a 2D flow field in VTK format, when I try to do probing, I cannot get any value from the flow field. So what I do is as following:

  1. click “Probe location” button
  2. set my cursor on the flow field, and “Ctrl+P” to pick up the nearest point
  3. “Apply”

as can be seen in the screenshot, that the C11 value should be 1.0, but not zero. And other flow parameters (like U,V,W…) they all have values but not zero.

So is there any thing wrong in my operation? Any suggestions are welcome, thank you.

Hi,

I have the feeling that your data is CellBased, right? If that’s the case, you should click on the “Attribute” drop down list and change “PointData” to “CellData”

Regards

Miguel

Dear Miguel,

Thank you for your reply, it is vertex based… and I tried CellBased as well, but none of them works. If you are willing to help me to check it, do you mind my sending you a .vtk file? It is very small, less than 1MB.

all the best,
Wenqiang

Hello,

Yes, no problem. Can you include your file as an attached file? I will take a look at that.

Regards

Miguel

2d.vtk (625.3 KB)

Dear Miguel,

Thank you so much. I have attached the file here.

kind regards,
Wenqiang

Hi,

Your data is OK. It is a Paraview related issue (I have this problem all the time). In fact, you have to pay attention to the X-coordinate of the probe point. Even though your plane is at X=0, in reality its points have non zero value due tu numerical errors. So, here is what I made:

I place my mouse pointer in the desired region, then I press “CTRL+P”, then click on “Apply” (do not forget to click on Apply). This works fine as you can see in this image:

Please, note that the X-coordinate of the point is NOT zero. Instead it has a very small value. Moreover, this value changes from one point to another.

If you try to set this coordinate to zero + click on Apply, I have the same error as you, i.e., C11 indicates 0 instead of 1.

I hope this helps !

Miguel

Dear Miguel,

That is what confuses me…I did exactly the same thing as you described, I did not change the x coordinate and just leave it as it is…but I still cannot get any value…


In fact, both I and my colleague have this problem. Do you think it is a problem due to different version? I notice that you are using a older version. And my system is Ubuntu 18.04. Let me try my Mac and your version…

kind regards,
Wenqiang

Dear Miguel,

It is quite funny, it should be a problem of the version. I tried 5.8.0 on Mac, the probing still has this problem. But when I switch to 5.2.0, well, it works…

Now I will test other versions and try to find the newest version which support the probing…

Thank you for you time, I appreciate it very much. I hope that the developers can see this post. I like Paraview, it is a good software and it is free.

cheers,
Wenqiang

Hi,

Perfect, I’m glad it solved your problem. Personally, I never used newer versions than PV5.6.0. So, effectivelly, this can be a bug.

Best regards

Miguel

@wenqiang, In looking at your screenshot, I think your problem is that the Radius parameter of your Probe Location filter is not set to 0. If radius is not set to 0, then the probe filter will randomly pick a point within the sphere of this radius. Because your data is 2D, it is almost certain that the point picked will be outside the plane.

Dear Kenneth,

Thank you for your suggestion, I tried your method, but it seems not work either…

I have attached the .vtk file I used in this webpage, I don’t know if you would like to try it?

kind regards,
Wenqiang

OK. I downloaded and looked at your data. I think the issue is a precision problem. The problem is that picking points on a 2D surface is finicky because you have to place the probe point exactly on the surface. Given that floating point numbers are themselves an imprecise representing of data, sometimes numbers don’t register as equal when they should.

Floating point numbers at 0 seem to compare better. If I edit your file to place the data at the x=0 plane, the probe filter seems to work. Here is your data with a minor modification to the file. (The change is on the 7th line of the file.)

2d-fixed.vtk (625.3 KB)

1 Like

Amazing! Ok, I see your point. So when I output this 2-D data I should force the X coordinate to be exactly 0. Thank you for your help.