Problem in the visualisation using paraview

I am new to Paraview, and I hope that someone will help me to solve my problem. I already conducted a simulation using OpenFOAM, and I converted the results of the last step to VTK to visualise them in the paraview. However, when I opened my data using Paraview,I could only see the cell ID and the solid colour. Not the results. I tried it several times, and still the output doesn’t show the results. Therefore, can someone help me in this regard?

You can open your OpenFOAM results directly in ParaView. No need to convert to .vtk.
Just create an empty .foam file in your OpenFOAM directory and open it with ParaView.

1 Like

Thank you very much Mathieu. I cant directly visualise the results since the simulation is running in a cluster and I am operating it in remotely. That’s why I need to download the VTK data and need to visualise them using my local computer.


Just download the OpenFOAM results instead.

You mean just the foam file?

Thank you very much. I will try.


Well no, the complete folder.

It is too big to download. That’s why I used the foamToVTK for the last time step and then download it for the visualisation. If my folder is too small or if it is run in my local computer, I can use the .foam file directly to visualise the results using the paraview. However, here my problem is something different. I have a really big folder, and I am working remotely using a cluster.

That’s why I used the foamToVTK

Then the problem is most likely with the foamToVTK logic.

Alternatlvely you can use pvserver or pvbatch to work on the cluster directly.

Can you please let me know what did you mean by error in foamToVTK logic? , I run the problem in serial, and then at the end of chtMultiRegionFoam, I applied the foamToVTK -time 10 . Do I need to modify it by any chance ?

No idea, foamToVTK is maintained by the OpenFOAM developers, not ParaView developers.