problem reading large VTU file

Hi,

I am having issues reading a large vtu file. I have tried various versions of Paraview on Windows and Ubuntu, but the problem is persistent. The VTU file consist of 404000 unstructured data points and when I try to load it, paraview says:

ERROR: In /build/paraview-vlxewD/paraview-5.7.0/VTK/IO/XML/vtkXMLUnstructuredDataReader.cxx, line 601 vtkXMLUnstructuredGridReader (0x560f46d55990): Cannot read cell offsets from Cells in piece 0 because the “offsets” array is not long enough.

I was wondering if this is a bug. Any help?

I have uploaded the VTU file here: deto_large_anim_1.vtu - Google Drive

Thanks in advance.

How was this file generated ?

Many arrays contains actual ***** instead of values, which is invalid.

Thanks for your answer. But this is not the source of the issue. When I manually change the ** values to “0”, it gives me the same error.

I found the same issue also in CFD forums: Problem opening vtu-file in Paraview -- CFD Online Discussion Forums

How was this file generated ?

Oops! sorry, I forgot to answer this question.

The file is generated by a Fortran code (as a part of a software). But when the number of data points in VTU is smaller (maybe up to 100000) it works fine. However, when the number of data points exceeds a certain value, then it becomes unreadable by Paraview.