pvbinsdash gfortran internal compiler error


(Cory Quammen (Kitware)) #1

Some gfortran compiler errors started showing up August 23 [CDash link] on pvbinsdaash. Only one commit (and subsequent merge) is different in the superbuild between the passing and failing test.

commit 78206458e7a2f4148ef6dbcfdb2e53e1789c27eb
Author: Cory Quammen <cory.quammen@kitware.com>
Date:   Mon Aug 13 23:44:55 2018 -0400

    Rename example data directory
    
    Changed from "data" to "examples".

ParaView has a number of changes, but none affecting BLAS (BLAS is an external dependency anyhow).

The same version of BLAS is used in the passing and failing tests, so I’m wondering @shawn.waldon if gfortran was updated/changed on pvbinsdash?


(Utkarsh Ayachit) #2

I was looking at it on Friday and will continue to look today. Will keep you posted. We tried the obvious things, like rebooting etc already to no avail.


(Cory Quammen (Kitware)) #3

Cool, thanks.


(Utkarsh Ayachit) #4

nothing obvious is jumping out. Not sure what changed. even going back to a version that previously worked causes the failure. Guess we’ll wait till Ben is back end of this week.


(Shawn Waldon) #5

As far as I can tell nothing changed between the last passing build and the first failing one. pvbinsdash is a docker image, so it should have stayed the same. Utkarsh and I (and Rob I think) are the only ones with access to that machine and we didn’t change anything.


(Cory Quammen (Kitware)) #6

What a welcome home :gift:!

I’ll vote for a cosmic ray flipping a bit somewhere.


(Dave DeMarle) #7

They were running a bunch of tests at the LHC that might be responsible too. :wink: