pvserver interactive points -> tag missmatch -> exit

I’m using ParaView 5.11 on a windows client and connect to a pvserver on a linux machine. Works generally really well. But when I try to query the model through e.g. ‘Interactive Select Points On’ or ‘Hover Points On’ then I get
[pvserver ]vtkSocketCommunicator.c:849 ERR| vtkSocketCommunicator (0x24feda0): Tag mismatch: got 1, expecting 10.
on the linux side and pvserver exits.
How do I fix this?

Hi @Dani

Please share exact stesp to reproduce. I’m unable to reproduce here.


I tried to set up a synthetic example, but did not manage to reproduce. The smallest actual example is more than 100 MB. So, I try first describing the steps without making large datasets available.

  1. Start pvserver on linux and connect from windows 5.11 ParaView
  2. Load pvd data file. 3D model, quite a few variables, several timesteps
  3. ‘Hover Points On’ works at this stage
  4. I have two materials in my model, the respective domains are marked by phase=0 and phase=1. I only want to see the parts of the model with phase=1 and use a threshold filter set to 0.1 and 1.
  5. If I now try to use ‘Hover Points On’ on the shown phase=1 part of the model then I get the described tag missmatch. pvserver then states ‘Exiting…’ but gets stuck. Using Ctrl-C at this stage spits out a stack trace. You find the whole command line output below.

Client connected.
( 572.906s) [pvserver ]vtkSocketCommunicator.c:849 ERR| vtkSocketCommunicator (0x1268d70): Tag mismatch: got 1, expecting 10.
( 572.942s) [pvserver ]vtkSocketCommunicator.c:849 ERR| vtkSocketCommunicator (0x1268d70): Tag mismatch: got 1, expecting 41235.
( 572.942s) [pvserver ]vtkSocketCommunicator.c:849 ERR| vtkSocketCommunicator (0x1268d70): Tag mismatch: got 1, expecting 41235.
( 585.484s) [pvserver ]vtkSocketCommunicator.c:783 ERR| vtkSocketCommunicator (0x1268d70): Could not receive tag. 1
( 585.484s) [pvserver ]vtkTCPNetworkAccessMana:295 ERR| vtkTCPNetworkAccessManager (0x1178c60): Some error in socket processing.
Loguru caught a signal: SIGINT
Stack trace:
21 0x40196d /home/schmid/ParaView-5.11.0-RC2-osmesa-MPI-Linux-Python3.9-x86_64/bin/pvserver-real() [0x40196d]
20 0x7f5af397ad0a __libc_start_main + 234
19 0x40188e /home/schmid/ParaView-5.11.0-RC2-osmesa-MPI-Linux-Python3.9-x86_64/bin/pvserver-real() [0x40188e]
18 0x7f5af24e5654 vtkInitializationHelper::Finalize() + 100
17 0x7f5af13a8ae2 vtkProcessModule::Finalize() + 98
16 0x7f5aedd199fa /home/schmid/ParaView-5.11.0-RC2-osmesa-MPI-Linux-Python3.9-x86_64/bin/…/lib/libvtkCommonCore-pv5.11.so.1(+0x6ae9fa) [0x7f5aedd199fa]
15 0x7f5aedbc0b29 vtkCallbackCommand::Execute(vtkObject*, unsigned long, void*) + 25
14 0x7f5aeb3131b6 /home/schmid/ParaView-5.11.0-RC2-osmesa-MPI-Linux-Python3.9-x86_64/bin/…/lib/…/lib/libvtkRemotingViews-pv5.11.so.1(+0x1e81b6) [0x7f5aeb3131b6]
13 0x7f5ad7b44a89 vtkOSOpenGLRenderWindow::~vtkOSOpenGLRenderWindow() + 9
12 0x7f5ad7b44a1c vtkOSOpenGLRenderWindow::~vtkOSOpenGLRenderWindow() + 28
11 0x7f5ad7b449e3 vtkOSOpenGLRenderWindow::Finalize() + 83
10 0x7f5ad7b44914 vtkOSOpenGLRenderWindow::DestroyOffScreenWindow() + 36
9 0x7f5ad610866b OSMesaDestroyContext + 27
8 0x7f5ad61373e8 /home/schmid/ParaView-5.11.0-RC2-osmesa-MPI-Linux-Python3.9-x86_64/bin/…/lib/…/lib/libOSMesa.so.8(+0x1a93e8) [0x7f5ad61373e8]
7 0x7f5ad6135e38 /home/schmid/ParaView-5.11.0-RC2-osmesa-MPI-Linux-Python3.9-x86_64/bin/…/lib/…/lib/libOSMesa.so.8(+0x1a7e38) [0x7f5ad6135e38]
6 0x7f5ad6c33acb /home/schmid/ParaView-5.11.0-RC2-osmesa-MPI-Linux-Python3.9-x86_64/bin/…/lib/…/lib/libOSMesa.so.8(+0xca5acb) [0x7f5ad6c33acb]
5 0x7f5ad6ade9c5 /home/schmid/ParaView-5.11.0-RC2-osmesa-MPI-Linux-Python3.9-x86_64/bin/…/lib/…/lib/libOSMesa.so.8(+0xb509c5) [0x7f5ad6ade9c5]
4 0x7f5ad6d9b544 /home/schmid/ParaView-5.11.0-RC2-osmesa-MPI-Linux-Python3.9-x86_64/bin/…/lib/…/lib/libOSMesa.so.8(+0xe0d544) [0x7f5ad6d9b544]
3 0x7f5ad6c611a5 /home/schmid/ParaView-5.11.0-RC2-osmesa-MPI-Linux-Python3.9-x86_64/bin/…/lib/…/lib/libOSMesa.so.8(+0xcd31a5) [0x7f5ad6c611a5]
2 0x7f5ad6c34a6b /home/schmid/ParaView-5.11.0-RC2-osmesa-MPI-Linux-Python3.9-x86_64/bin/…/lib/…/lib/libOSMesa.so.8(+0xca6a6b) [0x7f5ad6c34a6b]
1 0x7f5aed6577b2 pthread_cond_wait + 482
0 0x7f5af398fd60 /lib/x86_64-linux-gnu/libc.so.6(+0x38d60) [0x7f5af398fd60]
( 613.056s) [pvserver ] :0 FATL| Signal: SIGINT

Could you share the 100Mb dataset over a file upload service ?

Did you try to reproduce only on one machine, only linux or only windows ?

I’ve only tried one configuration, i.e. windows client - linux server. Works really well in general with a few hick-ups like the interactive point querying.
You find the example data set here:

I reproduce with your data, linux server linux client, no need for mpi.

TAG == 10 is broadcast, TAG == 1 is RMI (a very generic tag).

I’m unable to reproduce with other datasets so far.

Could you open an issue: https://gitlab.kitware.com/paraview/paraview/-/issues ?

Thanks for looking into this and confirming the issue. I filed the issue here: https://gitlab.kitware.com/paraview/paraview/-/issues/21841