pvserver remote rendering disabled

Hey,
I just set up pvserver on my cluster, but after connecting with my local client, I am always getting

Display is not accessible on the server side.
Remote rendering will be disabled.

This makes the visualization extremely slow and completely forfeits the purpose of setting up a pvserver.

I built paraview following instructions [here].(https://www.paraview.org/Wiki/ParaView:Build_And_Install#Run_ParaView_from_build)
I have VTK_OPENGL_HAS_OSMESA=OFF .

Later I realized the problem is discussed on this page, and specifically

One of the most difficult problems people face when installing a ParaView server is establishing XConnections. This whole problem can be circumvented by using the OSMesa library. However, Mesa is strictly a CPU rendering library so, use the OSMesa solution if and only if your server hardware does not have rendering hardware . If your cluster does not have graphics hardware, then compile ParaView with OSMesa support and use the --use-offscreen-rendering flag when launching the server.

So if I don’t request a GPU on the cluster, then do I have to use the OSMesa solution, i.e. I do not have rendering hardware (I am guessing the rendering hardware is the GPU)? However, even if I do request a GPU, I still run into the same problem…

I looked at some similar posts on this forum and others, such as this and this, but could not find a solution for “remote rendering disabled” even with the presence of a GPU.

Any pointers on how to setup remote rendering will be greatly appreciated!

To do offscreen rendering with GPU, you need to use an EGL build of pvserver assuming you have all the drivers properly setup and it is an nvidia gpu.

1 Like

Thank you so much for this helpful info. I didn’t find this anywhere before!
I ended up compiling again with OSMesa and is now using just software rendering. Now the “remote rendering disabled” message no longer appears, but the whole process is still slow compared with having data locally on my laptop.

Hi @axelwang ,

Indeed, it seems to be missing from docs.paraview.org.
It is documented here though:
https://kitware.github.io/paraview-docs/latest/cxx/Offscreen.html

I ended up compiling again with OSMesa and is now using just software rendering. Now the “remote rendering disabled” message no longer appears, but the whole process is still slow compared with having data locally on my laptop.

Just request a GPU and use the EGL release from https://www.paraview.org/download/ or build with EGL, it will be faster than OSMesa.

Best,